Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Не відображаються від'ємні залишки на початок періоду

Отрицательные остатки ошибки в отчете від'ємні залишки помилки у звіті

  • Авторизуйтесь для ответа в теме
Сообщений в теме: 2

#1   tarik_

tarik_

      Рядовой

    • Пользователи
    • Сообщений: 14
    • Регистрация: 31-July 10
    • Откуда:Львов , Львовская Область , Украина

Отправлено 26 March 2012 - 10:05

Всі привіт допоможіть розібратися із звітом, маю зовнішній матеріальний звіт, який показує кількісний облік (без ціни) проблема в тому що звіт не показує мінусові залишки на початок періода ( якщо вони є) а показу хіба кінцеві мінусові залишки, що треба змінити в звіті ?
1С Бухгалтерський облік для України 291 реліз, код звіта:
//*******************************************
// Процедура генерации запроса Сформировать1.
//
Процедура Сформировать()
	Перем Запрос, ТекстЗапроса, Таб;
	//Создание объекта типа Запрос
	Ит=СоздатьОбъект("БухгалтерскиеИтоги");
	Запрос = СоздатьОбъект("Запрос");
	ТекстЗапроса =
	"//{{ЗАПРОС(Сформировать1)
	|Период с НачДата по КонДата;
	|Контрагент = Документ.РасходнаяНакладная.Контрагент;
	|Валюта = Документ.РасходнаяНакладная.Валюта;
	|Курс = Документ.РасходнаяНакладная.Курс;
	|МестоХранения = Документ.РасходнаяНакладная.МестоХранения;
	|ТМЦ = Документ.РасходнаяНакладная.ТМЦ;
	|Кво = Документ.РасходнаяНакладная.Кво;
	|СуммаБезНДС = Документ.РасходнаяНакладная.СуммаБезНДС;
	|Функция КвоСумма = Сумма(Кво);
	|Функция СуммаБезНДССумма = Сумма(СуммаБезНДС);
	|Группировка Валюта;
	|Группировка Контрагент;
	|Группировка ТМЦ;
	|"//}}ЗАПРОС
	;
	// Если ошибка в запросе, то выход из процедуры
	Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
		Возврат;
	КонецЕсли;

	// Подготовка к заполнению выходных форм данными запроса
	Таб = СоздатьОбъект("Таблица");
	Таб.ИсходнаяТаблица("Сформировать");
	// Заполнение полей "Заголовок"
	Таб.ВывестиСекцию("Заголовок");
	Состояние("Заполнение выходной таблицы...");
	Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
	Пока Запрос.Группировка(1) = 1 Цикл
		// Заполнение полей Валюта
		Таб.ВывестиСекцию("Валюта");
		Пока Запрос.Группировка(2) = 1 Цикл
			// Заполнение полей Контрагент
			Таб.ВывестиСекцию("Контрагент");
			Пока Запрос.Группировка(3) = 1 Цикл
				// Заполнение полей ТМЦ
				Таб.ВывестиСекцию("ТМЦ");
			КонецЦикла;
		КонецЦикла;
	КонецЦикла;
	// Заполнение полей "Итого"
	Таб.ВывестиСекцию("Итого");
	// Вывод заполненной формы
	Таб.ТолькоПросмотр(1);
	Таб.Показать("Сформировать", "");
КонецПроцедуры

//////////////////////////////////////////////////////////////////////
Процедура Нова()
Перем Контраг,ИТ,ТабТМЦ;	
	Ит=СоздатьОбъект("БухгалтерскиеИтоги");
	Если ВыбМестаХранения.Выбран()=1 Тогда
		Ит.Использоватьсубконто(ВидыСубконто.МестаХранения,ВыбМестаХранения,2,);
	Иначе
		Ит.Использоватьсубконто(ВидыСубконто.МестаХранения,,1,);
	КонецЕсли;
	Если ВыбТМЦ.Выбран()=1 Тогда
		Ит.Использоватьсубконто(ВидыСубконто.ТМЦ,ВыбТМЦ,1,);
	Иначе
		Ит.Использоватьсубконто(ВидыСубконто.ТМЦ,,1,);
	КонецЕсли;
	Ит.Использоватьсубконто(ВидыСубконто.Партии,,3,);
	// Подготовка к заполнению выходных форм данными запроса
	Таб = СоздатьОбъект("Таблица");
	Таб.ИсходнаяТаблица("Сформировать1");
	// Заполнение полей "Заголовок"
	глУстПропись(Гривня);
	Таб.ВывестиСекцию("Заголовок");
	Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
	Счета=СоздатьОбъект("СписокЗначений");
	Счета.ДобавитьЗначение(СчетПоКоду("281"));
	Счета.ДобавитьЗначение(СчетПоКоду("282"));
	Счета.ДобавитьЗначение(СчетПоКоду("283"));
	Счета.ДобавитьЗначение(СчетПоКоду("284"));
	Счета.ДобавитьЗначение(СчетПоКоду("20"));	
	Счета.ДобавитьЗначение(СчетПоКоду("22"));	
	Счета.ДобавитьЗначение(СчетПоКоду("25"));
	Счета.ДобавитьЗначение(СчетПоКоду("26"));
	Ит.ВыполнитьЗапрос(НачДата,КонДата,Счета,,,1,"проводка",5);
		 Ит.ВыбратьСубконто(1);
		 Пока Ит.ПолучитьСубконто(1)=1 Цикл
			 СклНачСум=Ит.СНД();
			 СклПрих=Ит.ДО();
			 СклРасх=Ит.КО();
			 СклКонСум=Ит.СКД();
			 Если ВыбМестаХранения.Выбран()=0 Тогда
				 Таб.ВывестиСекцию("Склад");
			 КонецЕсли;
			 Ит.ВыбратьСубконто(2);
			 Пока Ит.ПолучитьСубконто(2)=1 Цикл
				 ТМЦПрихКво=Ит.ДО("К");
				 ТМЦРасхКво=Ит.КО("К");
				 ТМЦНачКВО=Ит.СНД("К");
				 Если Ит.СКД("К")=0 Тогда
					 ТМЦКонКВО=-Ит.СКК("К");
				 Иначе
					 ТМЦКонКВО=Ит.СКД("К");
				 КонецЕсли;
				 ТМЦПрих=Ит.ДО();
				 ТМЦРасх=Ит.КО();
				 ТМЦНач=Ит.СНД();
				 Если Ит.СКД()=0 Тогда
					 ТМЦКон=-Ит.СКК();
				 Иначе
					 ТМЦКон=Ит.СКД();
				 КонецЕсли;
				 Таб.ВывестиСекцию("ТМЦ");
				 КонецЦикла;
		 КонецЦикла;
		 Таб.ВывестиСекцию("Итого");
	Таб.ТолькоПросмотр(1);
	Таб.Показать("Сформировать1", "");
	
КонецПроцедуры  

//-----------------------------------------------
Процедура ПриОткрытии()
	Закрыть = 0;
	Обновить = 0;
	Дата1 = НачалоПериодаБИ();
	Дата2 = КонецПериодаБИ();
КонецПроцедуры

//-----------------------------------------------
Процедура ВводНового()
	Дата1 = НачалоПериодаБИ();
	Дата2 = КонецПериодаБИ();
КонецПроцедуры


дякую за допомогу
  • 1

#2   Valerka

Valerka

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1305
    • Регистрация: 03-April 08
    • Откуда:Каменец-Подольский

Отправлено 26 March 2012 - 10:56


//*******************************************

// Процедура генерации запроса Сформировать1.

//

Процедура Сформировать()

	Перем Запрос, ТекстЗапроса, Таб;

	//Создание объекта типа Запрос

	Ит=СоздатьОбъект("БухгалтерскиеИтоги");

	Запрос = СоздатьОбъект("Запрос");

	ТекстЗапроса =

	"//{{ЗАПРОС(Сформировать1)

.......

//			   ТМЦНачКВО=Ит.СНД("К");

// меняем на

				 Если Ит.СНД("К")=0 Тогда

					 ТМЦНачКВО=-Ит.СНК("К");

				 Иначе

					 ТМЦНачКВО=Ит.СНД("К");

				 КонецЕсли;

//конец изменений



				Если Ит.СКД("К")=0 Тогда

					 ТМЦКонКВО=-Ит.СКК("К");

				 Иначе

					 ТМЦКонКВО=Ит.СКД("К");

				 КонецЕсли;

				 ТМЦПрих=Ит.ДО();

				 ТМЦРасх=Ит.КО();

				 ТМЦНач=Ит.СНД();

				 Если Ит.СКД()=0 Тогда

					 ТМЦКон=-Ит.СКК();

				 Иначе

					 ТМЦКон=Ит.СКД();

				 КонецЕсли;

				 Таб.ВывестиСекцию("ТМЦ");

				 КонецЦикла;

		 КонецЦикла;

		 Таб.ВывестиСекцию("Итого");

	Таб.ТолькоПросмотр(1);

	Таб.Показать("Сформировать1", "");

	

КонецПроцедуры  


  • 3
Можно ответить на любой вопрос, если вопрос задан правильно.
Если сообщение помогло Вам - не забудьте нажать на МАЛЕНЬКУЮ стрелочку справа снизу Изображение

#3   tarik_

tarik_

      Рядовой

    • Пользователи
    • Сообщений: 14
    • Регистрация: 31-July 10
    • Откуда:Львов , Львовская Область , Украина

Отправлено 26 March 2012 - 12:13

Дякую
  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных