Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Спр.УстановитьАтрибут() не работает


  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1   ТемныйМагистр

ТемныйМагистр

      Рядовой

    • Пользователи
    • Сообщений: 15
    • Регистрация: 11-April 09
    • Откуда:Киев , Киев , Украина

Отправлено 12 December 2011 - 11:12

Фрагмент кода
=========================================

Книга = Эксель.WorkBooks.Open(файл);
Лист = Книга.WorkSheets(1);
НачатьТранзакцию();
кво = 0;
СпрТМЦ = СоздатьОбъект("Справочник.ТМЦ");
Для н=ССтр По ПоСтр Цикл
Артикул = СокрЛП(Строка(Лист.Cells(н, КолАртикул).Value));
Если ПустоеЗначение(Артикул) = 1 Тогда
Сообщить("Строка " + н + " Артикул пустой!!!");
Продолжить;
КонецЕсли;
Если СпрТМЦ.НайтиПоРеквизиту("Артикул",Артикул,1) = 1 Тогда
Если СпрТМЦ.ВыбратьЭлементы() = 1 Тогда
СпрТМЦ.ТекущийЭлемент();
УКТ1 = СокрЛП(Строка(Лист.Cells(н, КолЦена).Value));
СпрТМЦ.УстановитьАтрибут("УКТ", УКТ1);
СпрТМЦ.Записать();
Сообщить("Товар с артикулом " + Артикул + " -- Добавлен");
кво = кво + 1;
КонецЕсли;
Иначе
Сообщить("Товар с артикулом " + Артикул + " -- Ненайден");
КонецЕсли;
КонецЦикла;
ЗафиксироватьТранзакцию();
=========================================
Что видно в Отладчике
УКТ1 - нормально загружается и меняется с переходом по строкам
СпрТМЦ.УКТ - пустота, ничего не записывается. Реквизит не периодический. Тип Строка.
не могу понять почему даже в отладчите коменда
СпрТМЦ.УстановитьАтрибут("УКТ", УКТ1);
не выдает никакого значения
  • 0

#2   UACLUB

UACLUB

      Генералиссимус

    • Администраторы
    • Сообщений: 1426
    • Регистрация: 29-October 11
    • Откуда:Украина

Отправлено 12 December 2011 - 15:36

А так не пробовал:
СпрТМЦ.УКТ = УКТ1;
  • 0
Стремись к невозможному - получишь максимум!



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных