Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

- - - - -

Отчет "Виды затрат на реализованную готовую продукцию"


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 5

#1   vadim007

vadim007

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 146
    • Регистрация: 14-October 09
    • Откуда:Донецк, Украина

Отправлено 26 April 2011 - 15:23

Нет-ли у кого отчета "Виды затрат на реализованную готовую продукцию" для Бухии?
  • 0

#2   igmig65

igmig65

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 516
    • Регистрация: 05-July 07
    • Откуда: , ,

Отправлено 26 April 2011 - 15:36

?????? тут помоему все индивидуально, так как зависит от многих факторов самого учета затрат в производстве, тоесть как именно У ВАС он ведется.
  • 0

#3   vadim007

vadim007

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 146
    • Регистрация: 14-October 09
    • Откуда:Донецк, Украина

Отправлено 26 April 2011 - 16:08

Все даже общно: была реализация готовой продукции. Готовая продукция "производится" по Калькуляции, в которой расписаны все затраты. Нужно показать все затраты на реализованную готовую продукцию. Например: произвели 10 швабр. Затраты: амортизация, з/п, начисления на з/п, налоги, эл.энергия, гвозди, дерево. Реализовали 5 швабр. Нужно показать затраты на эти 5 швабр.
  • 0

#4   igmig65

igmig65

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 516
    • Регистрация: 05-July 07
    • Откуда: , ,

Отправлено 26 April 2011 - 16:35

стандартный запрос по калькуляциям, а нет пардон, там поле затрата тип неопределен, и нужно только затраты. Делал похожее давно, могу подсказать: стандартный запрос по калькуляциям, но добавить перед запросом:
ЗатрВид = "ВидыЗатрат";
и в запросе:
..............
Затр = Документ.Калькуляция.Затрата;
..............
Условие(Затр.Вид()=ЗатрВид);

если сложно пишите в ЛС

  • 0

#5   vadim007

vadim007

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 146
    • Регистрация: 14-October 09
    • Откуда:Донецк, Украина

Отправлено 27 April 2011 - 14:48

Обращение (запрос) к калькуляции - это уже в конце процесса. Наполовину задачу я уже решил:

Code
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ИспользоватьПланСчетов(ВыбранныйПланСчетов());
Если Метаданные.РазделительУчета.Выбран() = 1 Тогда
Ит.ИспользоватьРазделительУчета(Метаданные.РазделительУчета);
КонецЕсли;
Рез = Ит.ВыполнитьЗапрос(ВыбНачПериода,ВыбКонПериода,"901",,,2,3);
Если Рез = 0 Тогда
Сообщить("Ошибка выполнения запроса!!!");
Возврат;
КонецЕсли;
Если Ит.ВыбратьПериоды(1,1) = 1 Тогда
Пока Ит.ПолучитьПериод() = 1 Цикл
ТаблЧасть = 0;
Ит.Операция.Документ.ВыгрузитьТабличнуюЧасть(ТаблЧасть, "ТМЦ,Партия,Кво,Ед,СуммаБезНДС");
ТаблЧасть.ВыбратьСтроки();
Пока ТаблЧасть.ПолучитьСтроку() = 1 Цикл
Если ПустоеЗначение(тСтроки) = 1 Тогда
// Просто скопируем структуру табличной части
тСтроки = СоздатьОбъект("ТаблицаЗначений");
тСтроки.Загрузить(ТаблЧасть);
тСтроки.УдалитьСтроки();
// Добавим новые колонки
тСтроки.НоваяКолонка("ЕдиницаИзмерения");
тСтроки.НоваяКолонка("КодТМЦ");
КонецЕсли;
тСтроки.НоваяСтрока();
тСтроки.ТМЦ = ТаблЧасть.ТМЦ;
тСтроки.Кво = ТаблЧасть.Кво;
тСтроки.Ед = ТаблЧасть.Ед;
//! Цена без НДС единицы выпущенной продукции
тСтроки.СуммаБезНДС = ТаблЧасть.Партия.Док.СуммаПрод/ТаблЧасть.Партия.Док.КвоПродукции;
//! Себестоимость реализованной продукции в тыс.грн
тСтроки.СуммаБезНДС = тСтроки.СуммаБезНДС*тСтроки.Кво/1000;
тСтроки.КодТМЦ = ТаблЧасть.ТМЦ.Код;
КонецЦикла;
КонецЦикла;
КонецЕсли;

Осталось сгруппировать и в удобном виде вывести затраты на производство реализованной продукции.
  • 0

#6   igmig65

igmig65

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 516
    • Регистрация: 05-July 07
    • Откуда: , ,

Отправлено 28 April 2011 - 00:09

понятно, я вам предложил вариант отчета по затратам на призведенную продукцию. А вам нужно на реализованную. Чтоб получить реально затраты на именно ту продукцию, и если у вас учет не средневзвешенный, а в разрезе партий, то вам еще нужны партии, так как калькуляция автоматом формирует партию, соответственно вы можете вытянуть затраты на ед. произведенной продукции именно по этой партии.
  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных