Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Таблица значений на форме документа


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 5

#1   Uanr81

Uanr81

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 09-June 10
    • Откуда:Краматорск , Донецкая Область , Украина

Отправлено 19 March 2011 - 20:04

Здравствуйте. У меня на форме есть тз . Каким образом в модуле формы можно отследить изменение текущей строки тз (без добавления кнопки с процедурой). На форме есть картинка, и она изменяется в зависимости от текущей строки тз. Если дело шло про текст, там понятно привязать функцию а как быть с картинкой? Спасибо
  • 0

#2   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 19 March 2011 - 20:09

Аналогично как и текст...
только, по моему, еще нужно вставить
Форма.Обновить();
  • 0

#3   Uanr81

Uanr81

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 09-June 10
    • Откуда:Краматорск , Донецкая Область , Украина

Отправлено 19 March 2011 - 20:25

Ещё есть варианты?
  • 0

#4   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 19 March 2011 - 23:06

Если задача была понята правильно, то можно так попробовать:

Code
Перем ТекСтрока;

//*********************************************************************
Процедура ПриОткрытии()
ТекСтрока=Табл.НомерСтроки;
КонецПроцедуры //ПриОткрытии

//*********************************************************************
Функция СлежкаЗаСтрокой()
Пока Табл.НомерСтроки<>ТекСтрока Цикл
// устанавливаем/загружаем нужную картинку
КартинкаНаФорме.УстановитьКартинку(КартинкаДляТекСтроки);
ТекСтрока=Табл.НомерСтроки;
КонецЦикла; // Табл.НомерСтроки<>ТекСтрока
Возврат "";
КонецФункции //СлежкаЗаСтрокой

Функцию СлежкаЗаСтрокой() положить на форму.

  • 0

Услуги программиста 1С


#5   ivisor

ivisor

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1438
    • Регистрация: 06-March 08
    • Откуда:Планета Земля

Отправлено 20 March 2011 - 22:27

Quote (5_kopeek)
Функцию СлежкаЗаСтрокой() положить на форму

На форму нужно положить элемент диалога типа текст у которого в действии прописать СлежкаЗаСтрокой()
Только вчера такое делал smile
Code
Функция Обновить()    
  Если ТекСтр<>ТЗ.НомерСтроки Тогда
   АтрибутыФайла = "";
   ФС.АтрибутыФайла(ТЗ.Путь,,АтрибутыФайла,,,,);
   Если Сред(АтрибутыФайла,4,1)="0" Тогда // файл
    Попытка
     Снимок.Загрузить(ТЗ.Файл);
     Снимок.РежимРисования(Режим);
    Исключение
    КонецПопытки;  
   КонецЕсли;  
   ТекСтр = ТЗ.НомерСтроки;
  КонецЕсли;  
  Возврат "";
КонецФункции

  • 0

#6   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 20 March 2011 - 22:53

Quote (ivisor)
На форму нужно положить элемент диалога типа текст у которого в действии прописать СлежкаЗаСтрокой()

В качестве формулы. Собственно, об этом и речь была. Думала, само собой разумеется, объяснять нет необходимости.
  • 0

Услуги программиста 1С



Обратно в Программирование и конфигурирование 1С Предприятия 7.7

Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных