Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

работа с библиотекой картинок


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 11

#1   Uanr81

Uanr81

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 09-June 10
    • Откуда:Краматорск , Донецкая Область , Украина

Отправлено 27 February 2011 - 16:32

Здравствуйте , подскажите код модуля. в документе при активировании строки многостр. части нужно вывести картинку товара на форму. спасибо
  • 0

#2   Zaval

Zaval

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 1109
    • Регистрация: 26-December 07
    • Откуда: , ,

Отправлено 27 February 2011 - 17:50

Ну где-то же она выводится? Вот там и подсмотреть код.
  • 0
Киев

#3   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 27 February 2011 - 18:02

Мое решение вопроса было таким:
Создать папку с фото, где будут сохраняться файлы изображений товаров. Название каждого файла ассоциировать с кодом товара. (Можно организовать программным путем). Добавить на форму объект картинка. Загружать картинку при выборе строки при помощи метода Загрузить(ИмяФайла) по коду товара из текущей строки. Все.
  • 0

Услуги программиста 1С


#4   Uanr81

Uanr81

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 09-June 10
    • Откуда:Краматорск , Донецкая Область , Украина

Отправлено 27 February 2011 - 19:47

пишет общая файловая ошибка
процедура загрузитькартинку()
изо.Загрузить(строка(код));
конецпроцедуры
изо- идентификатор картинки на форме
код-код товара в строке многостр части
  • 0

#5   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 27 February 2011 - 20:00

Uanr81, ИмяФайла -- это не строка(код). Вы файлы назвали соответствующим образом? Путь к файлу должен быть в ИмяФайла, как и его расширение.
  • 0

Услуги программиста 1С


#6   Uanr81

Uanr81

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 09-June 10
    • Откуда:Краматорск , Донецкая Область , Украина

Отправлено 27 February 2011 - 20:06

при добавлении в библиотеку картинок идентификатор картинки соответствует коду товара
  • 0

#7   Zaval

Zaval

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 1109
    • Регистрация: 26-December 07
    • Откуда: , ,

Отправлено 27 February 2011 - 20:36

Не путайте картинку с пиктограммой. Пиктограмма может выводится в строке, колонке нужно поставить ВыводитьПиктограммы и передавать в нее идентификатор картинки в коллекции.
Картинка товара на форму - это нечто другое.
Запихивать картинки товаров в КоллекциюКартинок - плохая идея. Получите никаковенное качество и раздутый МДфайл.
  • 0
Киев

#8   Sercher2

Sercher2

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 28
    • Регистрация: 27-February 11
    • Откуда: , ,

Отправлено 27 February 2011 - 20:42

Если (Найти(СокрЛП(ФайлКартинки),".") = 0) и (ПустоеЗначение(ФайлКартинки) = 0) Тогда
ФайлКартинки = СокрЛП(ФайлКартинки) +".jpg";
КонецЕсли;
Если ((ФС.СуществуетФайл(КаталогИБ()+Прав(СокрЛП(Константа.КаталогКартинок),СтрДлина(СокрЛП (Константа.КаталогКартинок))-3) +"\" +СокрЛП(ФайлКартинки)) = 1) и (СокрЛП(файлКартинки) <> "")) и (ИспользоватьКарт <> 1) Тогда
фКарт.Загрузить(КаталогИБ()+Прав(СокрЛП(Константа.КаталогКартинок),СтрДлина(СокрЛП(Константа.КаталогКартинок))-3) +"\"+СокрЛП(ФайлКартинки));
Иначе
фКарт.Загрузить(КаталогИБ()+Прав(СокрЛП(Константа.КаталогКартинок),СтрДлина(СокрЛП(Константа.КаталогКартинок))-3) +"\"+"НетФото.jpg");
КонецЕсли;

так я сделал у себя, это в форме справочника ТМЦ на закладке картинка, печатается фото товара, фотки расположены в каталоге, и их имена записаны в конкретном элементе справочника wink что-то сложно объясняю но думаю в коде разобраться можно если не понятно, но интересно спрашивайте

  • 0

#9   Uanr81

Uanr81

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 09-June 10
    • Откуда:Краматорск , Донецкая Область , Украина

Отправлено 27 February 2011 - 21:51

нужно привязать к базе каталог с картинками, чтобы можно было сохранять данные с последующей загрузкой
  • 0

#10   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 27 February 2011 - 22:23

У меня так:
Code

Функция ПоказатьФото()
  // попытаемся установить фото  
  ПустаяКартинка=СоздатьОбъект("Картинка");
  КаталогФотографий = КаталогИБ() + "Photo\";
  ФайлФото = КаталогФотографий + "ph" + СокрЛП(Строка(ТекущийЭлемент().Код))+".*";
  Если ФС.СуществуетФайл(ФайлФото) = 1 Тогда
   Фото.Загрузить(КаталогФотографий+ФС.НайтиПервыйФайл(ФайлФото));   
  Иначе
   Фото.УстановитьКартинку(ПустаяКартинка);
  КонецЕсли;   
  Возврат "";
КонецФункции //ПоказатьФото()

Это для отображения фото в форме списка товаров. Как видно, папка с фото находится в каталоге ИБ. А для ее сохранения добавьте маску в список сохранения.
  • 0

Услуги программиста 1С


#11   Uanr81

Uanr81

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 09-June 10
    • Откуда:Краматорск , Донецкая Область , Украина

Отправлено 27 February 2011 - 23:31

С этим ясно. Можно не указывать путь к файлу, если он лежит в каталоге иб. Интересует как привязать этот каталог к базе, чтобы можно было его выгрузить вместе с базой при сохранении данных.
  • 0

#12   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 28 February 2011 - 00:09

Файл лежит во вложенном в каталог ИБ каталоге. И, хотя могу и ошибаться, каталогом по умолчанию для поиска файлов является каталог пользователя, а не каталог ИБ.
Quote (Uanr81)
можно было его выгрузить вместе с базой при сохранении данных

Так Вас интересует сохранение или выгрузка? Если сохранение, то, как я уже сказала, добавьте маску в список сохранения.
Администрирование => Сохранить данные => Добавить маску =>
В моем случае это PHOTO\*.*.
  • 0

Услуги программиста 1С




Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных