Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Как вытянуть данные из справочника в документе


  • Авторизуйтесь для ответа в теме
В этой теме нет ответов

#1   pashik

pashik

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 20-February 11
    • Откуда: , ,

Отправлено 22 February 2011 - 10:16

Всем привет!
Я новичек в 1С. Пишу себе конфу на 8.2.
Есть справочник номенклатура с реквизитами: Наименование, единицы измерения.
Есть документ - Приход товара с табличной частью.
Как сделать, чтоб при выборе в табличной части какойто номенклатуры, единицы измерения подставлялись автоматически (из справочника Номенклатура).
Заранее благодарен.

Добавлено (22.02.2011, 10:16)
---------------------------------------------
Уже сам допетрил. Если кому нада:

Code
&НаКлиенте
Процедура СписокТоваровНоменклатураПриИзменении(Элемент)
  СтрокаТабличнойЧасти = Элементы.СписокТоваров.ТекущиеДанные;
  СтрокаТабличнойЧасти.Цена = РаботаСоСправочниками.ИзвлечЦену(Объект.Дата, СтрокаТабличнойЧасти.Номенклатура, Объект.ВидЦены);
КонецПроцедуры

&НаКлиенте
Процедура СписокТоваровНоменклатураОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
  СтрокаТабличнойЧасти = Элементы.СписокТоваров.ТекущиеДанные;
  СтрокаТабличнойЧасти.ЕдиницыИзмерения = ИзвлечЕдиницыИзмерения(ВыбранноеЗначение);
КонецПроцедуры

//Функция - извлечение единицы измерения из справочника
&НаСервереБезКонтекста
Функция ИзвлечЕдиницыИзмерения(ВыбранноеЗначение)
  Возврат ВыбранноеЗначение.ЕдиницыИзмерения;  
КонецФункции

  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных