Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Реєстр податкових накладних


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 15

#1   volodymyr1981

volodymyr1981

      Рядовой

    • Пользователи
    • Сообщений: 18
    • Регистрация: 14-September 09
    • Откуда:Львов , Львовская Область , Украина

Отправлено 09 February 2011 - 10:59

Всім привіт.

Допоможіть вирішити проблему.
1С 7,7 мережева 025 - Комплексна конфа 035 - нові регламентовані звіти
При формуванні реєстру податкових накладних в клієнта, який не має податкових кодів (тобто відвантажуємо товар неплатнику ПДВ, в податковій вказуємо, що залишаємо в себе) - воно замість нулів ставить код попереднього клієнта... То у всіх так чи то в мене тільки заглюкало....

  • 0

#2   pashenkoav

pashenkoav

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 09-February 11
    • Откуда:Донецк , Донецкая Область , Украина

Отправлено 09 February 2011 - 15:44

Проблема решается следующим способом:
изменяете код со строки 1987 по 1993

ИначеЕсли Запр.Оставляем = 1 Тогда
Если СРЕД(СОКРЛП(Запр.ТипПричины),2,2) = "02" Тогда
ИННКонтр = 0;
КонецЕсли;
Иначе
ИННКонтр = СокрЛП(Запр.Контрагент.ИНН);
КонецЕсли;

НА СЛЕДУЮЩИЙ:

ИначеЕсли (Запр.Оставляем = 1) и (СРЕД(СОКРЛП(Запр.ТипПричины),2,2) = "02") Тогда
ИННКонтр = 0;
Иначе
ИННКонтр = СокрЛП(Запр.Контрагент.ИНН);
КонецЕсли;

Добавлено (09.02.2011, 13:38)
---------------------------------------------
В реестре выскочила следующая ошибка при выгрузке в XML....


====== Реестр налоговых накладных для декларации по НДС
-- Начало загрузки схемы (J1201505.xsd)
-- Схема загружена успешно!
--- Начало выгрузки в файл 05660035682910J120150510000001092010.xml
Ошибка при выполнении команды;
--- Отчет выгружен успешно!
---- Начало проверки отчета по xsd-схеме.
: minInclusive constraint failed.
The element: 'T1RXXXXG6' has an invalid value according to its data type.
[</T1RXXXXG6> (error position = 4)]
---- Проверка завершена!

Имя некорректно заполненного показателя как он определен в XML-схеме Описание ошибки
T1R000001G6 Значение не является целым числом от 1000 до 999999999999
T1R000002G6 Значение не является целым числом от 1000 до 999999999999
T1R000003G6 Значение не является целым числом от 1000 до 999999999999
T1R000004G6 Значение не является целым числом от 1000 до 999999999999
T1R000005G6 Значение не является целым числом от 1000 до 999999999999
T1R000006G6 Значение не является целым числом от 1000 до 999999999999
T1R000007G6 Значение не является целым числом от 1000 до 999999999999
T1R000009G6 Значение не является целым числом от 1000 до 999999999999

Может кто че подскажет? cry

Добавлено (09.02.2011, 14:42)
---------------------------------------------
Это значения в поле "ИНН". Если не плательщик - то значение = 0 и проверка не проходится...
Кто знает .. где можно изменить параметры проверки "Значение не является целым числом от 1000 до 999999999999"
Может если изменить " от 0 до 999999999999 " тогда заработает???

Добавлено (09.02.2011, 15:44)
---------------------------------------------
На одном из форумов подсказали....... tongue
В файле \extforms\Rp11q1.grp\xsd\comtypes.xsd
в строке 740 меняем 1000 на 0

<!--Загальний тип "Індивідуальний податковий номер "-->
<xs:simpleType name="DGLong12">
<xs:restriction base="xs:unsignedLong">
<xs:minInclusive value="0"/>
<xs:maxInclusive value="999999999999"/>
</xs:restriction>

  • 0

#3   ivisor

ivisor

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1438
    • Регистрация: 06-March 08
    • Откуда:Планета Земля

Отправлено 10 February 2011 - 12:07

ОПЗ 0 не хавает
  • 0

#4   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 10 February 2011 - 12:12

Quote (ivisor)
ОПЗ 0 не хавает

Повторюсь, схема стандартная, надо не схему править, а модули заполнения и/или выгрузки.
/forum/3-1513-198
  • 0

Услуги программиста 1С


#5   ivisor

ivisor

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1438
    • Регистрация: 06-March 08
    • Откуда:Планета Земля

Отправлено 10 February 2011 - 13:59

С вашего разрешения под итожу: (уточню что реестр из отчетности 1 кв 2011 №2 для бухгалтерии)
В запросе ошибка в типе причины. Меняем строку
Code
//|ТипПричины = Документ.НалоговаяНакладная.СпецРежимНалогообложения;

На
Code
//|ТипПричины = Документ.НалоговаяНакладная.СпецРежимНалогообложения;
|ТипПричины = Документ.НалоговаяНакладная.ТипПричины;

Да лее в коде (находим по поиску) меняем строку:

Code
  ИННКонтр = "0";

на:
Code
  ИННКонтр = "0";
         Если Запр.Оставляем = 1 Тогда
          Если СРЕД(СОКРЛП(Запр.ТипПричины),2,2) = "02" Тогда
           ИННКонтр = "";         
          КонецЕсли;     
         КонецЕсли;

Что позволит реестру продолжить ругатся на незаполненные ИНН в случае если НН у себя не оставляем или код причины отличный от 02

Да - кстати! Бухгалтерам!
В форме можно ВРУЧНУЮ убрать 0 в ИНН и отчет ВЫГРУЗИТСЯ!

  • 0

#6   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 10 February 2011 - 14:28

ivisor, я немного иначе делала. И у меня были какие-то нюансы с
Code
Если флЭкспортБест = 1 Тогда

, не могу вспомнить
Code
   Если Число(ИННКонтр) = 0 Тогда
     Если флЭкспортБест = 1 Тогда
      ИННКонтр = 0;
     // Добавлено 5_копеек (начало)  
     ИначеЕсли СокрЛП(ИННКонтр)="Х" Тогда
      ИННКонтр = "Х";
     // Добавлено 5_копеек (конец)  
     Иначе
      ИННКонтр = "0";
     КонецЕсли;
    КонецЕсли;

Собственно, "Х" или "" -- не имеет значения.
Но это еще не все: итоговые по рознице, распределение НДС. Второй раздел пока только неправильно заполняемый вид документа исправила, больше ничего не обнаружила.
Вечером постараюсь подробнее изложить.

Услуги программиста 1С


#7   nicst

nicst

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 02-April 08
    • Откуда: , ,

Отправлено 11 February 2011 - 13:31

Quote (5_kopeek)
больше ничего не обнаружила.

Во втором разделе желательно добавить такое:

Code
Если Число(ИННКонтр) = 0 Тогда                 
    Если Запр.Импорт = 1 Тогда    
      Нерез = 1;  
      Если (Запр.НН.ВаловыеРасходы = 0) или (Запр.НН.ДляПоставкиуслуг = 1) Тогда
        ИННКонтр = "200000000000";  
      Иначе
        ИННКонтр = "300000000000";  
      КонецЕсли;
   Иначе
       ВидДок = "НП"; //++ получено от неплательщика
       ИННКонтр = "400000000000";  
   КонецЕсли;
КонецЕсли;


#8   Polukuzov

Polukuzov

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 324
    • Регистрация: 23-April 08
    • Откуда: , ,

Отправлено 11 February 2011 - 16:07

Во втором разделе желательно добавить такое:
Ничего не надо добавлять! Ругаеться так как в НН неплательщиков нужно ставить отметку "Оставляем НН у себя". Тогда все нормально.
  • 0

#9   viktorika

viktorika

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 33
    • Регистрация: 22-February 10
    • Откуда:Киев , Киев , Украина

Отправлено 11 February 2011 - 16:16

Второй раздел - полученные налоговые накладные (с 01.01.2011 разделы в Реестре поменялись местами) - в Записи книги приобретения нельзя поставить - оставляем у себя.
  • 0

#10   nicst

nicst

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 02-April 08
    • Откуда: , ,

Отправлено 11 February 2011 - 16:45

Quote (Polukuzov)
Ничего не надо добавлять!

Повторяю медленно:
-при заполнении кода вида документа для неплателщиков НДС (раздел 2 реестра)
а он называется - "Розділ ІІ. Отримані податкові накладні"
- нужно "НП" вместо "-".
Я это исправил добавив строчку: ВидДок = "НП"; //++ получено от неплательщика
и показал кусок кода, куда вставлять...

P.S/
В Релизе I квартал 2011 (3) от 11 февраля 2011 г. эта ошибка исправлена!

  • 0

#11   tttbuh

tttbuh

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 107
    • Регистрация: 04-June 09
    • Откуда: , ,

Отправлено 11 February 2011 - 22:18

Хочу вернуться к теме реестра в интерпретации фирмы 1С.Мне кажется, что он сделан не по правилам, диктуемым "Порядком ведення...".Сейчас хвост (реестр) крутит собакой (бухгалтером).То есть я, для совпадения граф 1-й и 3-й, должна буду в конце месяца перенумеровать НН, потому что сейчас выборка идет хронологически, т.е. по датам, и поэтому порядковый номер строки графы №1 вполне может жить отдельной жизнью от номера в графе №3 (это № НН). А по закону они теперь сиамские близнецы. А вот как раз насчет даты законодатели ничего важного не проблеяли.Просто скромно и со вкусом : «9.2. У графі 2 вказується дата виписки податкової накладної». Если им (ГНАУ) так важно совпадение номеров, так может на дату можно не обращать внимания?.Какая есть, такая и есть.Т.е. в реестре можно как-то поменять приоритет?Выбирать по № НН, а уж дата (графа 2) как сложится. ?Это возможно? Или вообще не заморачиваться? Со временем само как-то пройдет?
  • 0

#12   kuriban

kuriban

      Рядовой

    • Пользователи
    • Сообщений: 11
    • Регистрация: 11-November 10
    • Откуда: , , Украина

Отправлено 15 February 2011 - 22:00

Quote (tttbuh)
так важно совпадение номеров, так может на дату можно не обращать внимания?

Действительно, на дату не нужно обращать внимания. Я долго воевал с бухгалтером по этому поводу, что невозможно сделать так, чтобы порядковый номер в реестре совпадал с номером документа и еще чтобы дата была в хронологическом порядке. Спор закончился после того, как бухгалтер показал распечатку из налоговой с примером заполнения реестра. В общем, порядковый номер совпадает с номером документа без привязки к дате. Жду, когда выйдет обновленный реестр для 1С

Добавлено (15.02.2011, 22:00)
---------------------------------------------
Выкладываю переделанный реестр НН, в котором порядковый номер совпадает с номером накладной (при условии, что назначен нумератор для НН и приложеня №2) http://depositfiles....files/6b5al72hu

  • 0

#13   pepe

pepe

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 1148
    • Регистрация: 12-April 08
    • Откуда: , ,

Отправлено 15 February 2011 - 22:06

kuriban, А что у вас получиться в реестре, если вы ошибочно создали документ (НН или приложение), а потом удалили его. Что будет, если в реестр надо внести информацию согласно БО?
Сегодня одним из ответов налоговой было - Налоговые нумеровать в пределах года, реестр будут принимать начиная с порядкового номера, следующего из старого, сданного реестра. Реестр за февраль не должен идти с порядковым номером 1.
  • 0
Спасибо не надо, помог - есть "+" в репутацию.

#14   kuriban

kuriban

      Рядовой

    • Пользователи
    • Сообщений: 11
    • Регистрация: 11-November 10
    • Откуда: , , Украина

Отправлено 15 February 2011 - 23:56

Сколько налоговых, столько и ответов. Бухгалтера двух фирм, которые я обслуживаю, в один голос вопят, что нумерация начинается с 1 каждый месяц. А что касается удаленных накладных, то бухгалтеры в конце месяца определяют, какие номера отсутствуют и восполняют недостачу.
  • 0

#15   pepe

pepe

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 1148
    • Регистрация: 12-April 08
    • Откуда: , ,

Отправлено 15 February 2011 - 23:59

Quote (kuriban)
бухгалтеры в конце месяца определяют, какие номера отсутствуют и восполняют недостачу

Я о том, что в 1С вы документ пометите на удаление, номер будет занят, что будет в реестре - дырка?
  • 0
Спасибо не надо, помог - есть "+" в репутацию.

#16   kuriban

kuriban

      Рядовой

    • Пользователи
    • Сообщений: 11
    • Регистрация: 11-November 10
    • Откуда: , , Украина

Отправлено 16 February 2011 - 00:13

Ведь этот вопрос решаем: удаляем или переносим в предыдущий месяц и меняем номер (оставляя удаленной) и т.п.
  • 0


Обратно в Программирование и конфигурирование 1С Предприятия 7.7

Похожие темы




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных