Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Как правильно внести список в форму


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 26

#21   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 08 February 2011 - 20:00

Igor_S, БЛИН... к... т.... в... з...
у меня уже слов нету....
учите мат.часть

читай пост №12
я все написал...
тебе только строчки нужно вставить!!!!

  • 0

#22   Igor_S

Igor_S

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 32
    • Регистрация: 21-December 10
    • Откуда:Киев , Киев , Украина

Отправлено 08 February 2011 - 20:44

Quote (Max_Nj)
Igor_S, БЛИН... к... т.... в... з...
у меня уже слов нету....
учите мат.часть
читай пост №12
я все написал...
тебе только строчки нужно вставить!!!!

Добавлял (это реквизиты уже понял), но все равно нечего не происходило. Завтра еще попробую , но что пробовать не знаю.

Извините за мою безграмотность cry

Добавлено (08.02.2011, 20:44)
---------------------------------------------

Quote (ivisor)
gor_S, А зачем ты создавал справочник? Если уж так надо - то посмотри как реализована причина, по которой НН оставляют у себя - можно сделать вид договора по такому же принципу

Смотрел - внимания сильно не уделил, посмотрю завтра это еще, спасибо.

  • 0

#23   tttbuh

tttbuh

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 107
    • Регистрация: 04-June 09
    • Откуда: , ,

Отправлено 08 February 2011 - 21:04

Igor_S, перед тем, как что-то сделать, надо самому себе ответить на вопрос -а что я хочу получить в результате? Если просто разные виды договоров в печатной форме НН, т. е. на бумажке, так совет Ivisorа очень правильный. Можно привязать вид договора к виду документа, например, если НН по расх. накл, - то "договір купівлі- продажу", если НН по оказанию услуг,-то " договір виконання робіт", и т.д. и.т.п. и все это будет автоматом печататься в НН.И тогда справочник и все остальное не нужны.Ну а если наименование договора несет большую смысловую нагрузку, оно очень информативно и важно для бухгалтера, то тогда да, есть смысл в справочнике и сохранении наименовании договора.
  • 0

#24   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 08 February 2011 - 23:20

Igor_S, Как это работает!!!!!!
Делаешь новый документ НН
изменяешь то, что надо!!!
закрываешь!
И только после этого - следующий новы документ будет с нужными данными
  • 0

#25   ivisor

ivisor

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1438
    • Регистрация: 06-March 08
    • Откуда:Планета Земля

Отправлено 09 February 2011 - 01:24

Igor_S,
В начале модуля формы НН добавляешь 2 процедуры
Code
// ===============================
Процедура ЗаполнитьВидыДоговоров()
   спВидыДоговоров.УдалитьВсе();
   спВидыДоговоров.ДобавитьЗначение("Договір купівлі-продажу");
   спВидыДоговоров.ДобавитьЗначение("Договір виконання робіт");
   спВидыДоговоров.ДобавитьЗначение("Тут");
   спВидыДоговоров.ДобавитьЗначение("Вписываешь");
   спВидыДоговоров.ДобавитьЗначение("Нужные");
   спВидыДоговоров.ДобавитьЗначение("Виды");
   спВидыДоговоров.ДобавитьЗначение("Договоров");
     
   Инд = спВидыДоговоров.НайтиЗначение(СокрЛП(ВидДоговора));
   Если Инд = 0 Тогда // нет такого в списке
    спВидыДоговоров.ТекущаяСтрока(1);
    ВидДоговора = спВидыДоговоров.ПолучитьЗначение(1);
   Иначе
    спВидыДоговоров.ТекущаяСтрока(Инд);
   КонецЕсли;
КонецПроцедуры

// ===============================
Процедура ИзмВидДоговора()
   Инд = спВидыДоговоров.ТекущаяСтрока();
   Если Инд <> 0 Тогда
    ТекВидДоговора = спВидыДоговоров.ПолучитьЗначение(Инд);
    Если ТекВидДоговора <> ВидДоговора Тогда
        ВидДоговора = ТекВидДоговора;
    КонецЕсли;
   КонецЕсли;
КонецПроцедуры

В конец процедуры ПриОткрытии() добавляешь строку:

Code
    ЗаполнитьВидыДоговоров();

А на форме удаляешь реквизит ВидДоговора и вместо него вставляешь элемент диалога - поле со списком (как спТипПричины)
Называешь его спВидыДоговоров, а в поле формула вписываешь ИзмВидДоговора()
Аминь.

  • 0

#26   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 09 February 2011 - 02:39

Igor_S, ivisor очень добр к Вам. Цените.
Обратите внимание, что в примере ivisorа не будет сохраняться выбранный в предыдущем документе вид договора (как Вы хотели), т.е. при вводе новой накладной вид договора будет заполняться первым видом из списка спВидыДоговоров. Поэтому, для удобства, первым впишите самый частоупотребляемый вид договора.
А если хотите чему-то научиться, то, кроме анализа предложенного ivisorом кода, постарайтесь довести свою реализацию со справочником до конца. Всю информацию Вам дали.
Code
СохранитьЗначение("ВидДоговора_Док",ВидДоговора);

, где
ВидДоговора_Док -- это не совсем переменная, а строка с произвольным именем (идентификатором) сохраняемого значения, поэтому объявлять ее нигде не надо;
ВидДоговора -- собственно значение реквизита (или переменной), которое сохраняется под этим именем.
В стандартной налоговой уже есть текстовый реквизит с идентификатором ВидДоговора, поэтому либо проследите за уникальностью идентификатора Вашего нового реквизита, либо модифицируйте существующий, изменив его тип <<Строка>> на тип Справочник.ИмяСозданногоВамиСправочникаДоговоровКакОноЗаданоВКонфигураторе. Если будете изменять, в печатной форме желательно использовать выражение ВидДоговора.Наименование.
Хотя, если в Вашей налоговой действительно нет процедуры ПриЗаписи(), маловероятно что этот документ стандартный.
Quote
Пробовал все по разному, не знаю почему неработает

Чтобы хоть кто-то понял, почему не работает, цитируйте, что именно Вы делали "все по разному".
P.S. Предполагаю, что следующим вопросом (после решения этого) будет автозаполнение даты и номера договора.
  • 0

Услуги программиста 1С


#27   Igor_S

Igor_S

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 32
    • Регистрация: 21-December 10
    • Откуда:Киев , Киев , Украина

Отправлено 09 February 2011 - 08:36

Огромное спасибо всем!!!
Буду трудиться, что бы сделать.
Насчет того что я не знаю что я хочу скажу - мне бухи каждый раз что то новое придумывают, вот и сам путаюсь как это объяснить.
  • 0


Обратно в Программирование и конфигурирование 1С Предприятия 7.7

Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных