Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Бухгалтерия 281 ЕСВ недоработки


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 43

#1   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 04 February 2011 - 17:36

Ну вот, долго-долго обсуждали тему ошибок/недоработок в налоговой накладной...
А теперь давайте поговорим на тему ЗП и ЕСВ в зароботной плате.

1. Первое что вылезло - провсоюз.
он вобще несчитается в новой ЗП, но это все мелочь и решается добавлением одной строки!

2. Вот более серьезная проблема:
ЕСВ для нескольких фирм в одной базе!
как выяснелось. если в одной базе ведетса несколько фирм, и ЕСН у этих фирм - разный, то в программе правельный расчет будет только для одной фирмы.

Предлагаю "облизать" эту тему!!!
У кого какие умные мысли есть?

P.S. Попрошайкам не сюда!!!

  • 2

#2   Hantinka

Hantinka

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 103
    • Регистрация: 16-February 10
    • Откуда:Запорожье , Запорожская Область , Украина

Отправлено 04 February 2011 - 17:39

Ещё неудобно, что используется 651 счёт, если есть дебиторская задолженность ПФ...
  • 0

#3   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 04 February 2011 - 17:45

Так ведь там аналитика разная!
пусть бухгалтера правильно разносят БВ
  • 2

#4   ivisor

ivisor

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1438
    • Регистрация: 06-March 08
    • Откуда:Планета Земля

Отправлено 04 February 2011 - 17:57

Quote (Max_Nj)
У кого какие умные мысли есть?

МЫсль пока приходит только одна ...
Создавать для каждой фирмы свою ставку в справочнике налогов. Коды ставок формировать с учетом префикса нумерации фирмы, а при расчете ЗП ставу налога получать путем прибавления кода к префиксу. Вот как-то так ...
  • 0

#5   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 04 February 2011 - 19:55

ivisor, Помоему слишком замороченно выйдет....
Для каждой фирмы создавать строку в спр...
потом, при изминении ставок все менять
а про начало года я вобще молчу...

нет - это не выход (мое мнение)

  • 2

#6   nvru

nvru

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 02-February 11
    • Откуда:Харьков , Харьковская Область , Украина

Отправлено 04 February 2011 - 20:49

Добавить реквизит ставка ЕСВ в справочник Фирмы
  • 0

#7   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 04 February 2011 - 21:26

nvru, А дальше?
Идея хорошая, таким путем пошли программеры Форт2000/XP.
Тут это не пройдет, т.к. самом модуле ЗП все привязки идут к спр. НалогиОтчисления(((
  • 2

#8   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 04 February 2011 - 23:14

А мне идея ivisor нравится -- вполне универсально и довольно просто.
Quote (Max_Nj)
Для каждой фирмы создавать строку в спр... потом, при изминении ставок все менять а про начало года я вобще молчу...

Ставки в любом случае изменять придется, если они изменятся, куда бы их не заносили.

Max_Nj, у Вас есть идея поинтереснее?

Реквизит ЕСВ справочника Фирмы намного заморочнее. Лучше уж реквизит для коэффициента перерасчета из ставки основной фирмы, но начнутся нюансы с точностью, зато останутся подвязки под НиО.

  • 0

Услуги программиста 1С


#9   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 05 February 2011 - 00:05

Quote (5_kopeek)
Реквизит ЕСВ справочника Фирмы намного заморочнее.

Все классно получается!!!
добавляем переодический рекв. в спр фирмы
в доке НачислениеЗП
в модуле провидения и в основном модуле всего несколько строк кода...
и там и там в Функция ПолучитьСтавку(ИмяПараметра)
добавляем:
Code

  Если (ИмяПараметра="ФЗПЕСВ") И (Фирма.Выбран()=1) Тогда
      Попытка
    Ставка=Фирма.СтавкаЕСВ.Получить(ДатаДок);
    Если Ставка<>0 Тогда
     Возврат Ставка
    КонецЕсли;
      Исключение
      КонецПопытки;
  КонецЕсли;

И все работает просто замечательно!!!
причем при любом сареанте, т.е. если забыли проставить ставку для фирмы,
то берет из спр стандартную.

Ура заработало!!!
booze booze booze

  • 2

#10   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 05 February 2011 - 00:15

Quote (Max_Nj)
Ура заработало!!!

Ну и чудненько! smile
Осталось надеяться, что завтра не придумают еще какой-нибудь уникальный для каждой фирмы налог или не начнут изменять ставку в средине месяца;)
  • 0

Услуги программиста 1С


#11   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 05 February 2011 - 00:20

5_kopeek, Да тут еще одна проблема вылезла!!!
Не считает ЕСП из зп работника по договору-подряда
  • 1

#12   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 05 February 2011 - 00:24

Quote (Max_Nj)
Не считает ЕСП из зп работника по договору-подряда

В смысле ЕСВ? Читала в другой ветке. Там же и ответила)
Для решения много вариантов.
  • 0

Услуги программиста 1С


#13   Zaval

Zaval

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 1109
    • Регистрация: 26-December 07
    • Откуда: , ,

Отправлено 05 February 2011 - 18:36

Как раз вчера сделал сабжевую штуку в БухУчете)))

Max_Nj, это оно в ПолучитьСтавку() заработало... а как с ПолучитьНиО()?
Тоже вначале такой вариант пробовал. Но вот когда формируется таблица из налогов, то ставку в явном виде уже не запрашивает... придется перехватывать и кроить табЗначений...
В общем, сделал через клоны ФЗПЕСВ (подробно описано у ivisor, пост 4). Минимум дописок(делается комфортно за 15-20 минут), копии налогов в справочнике создала ГБ по инструкции в несколько строк. Все довольны)))

  • 0
Киев

#14   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 05 February 2011 - 23:41

Quote (Zaval)
а как с ПолучитьНиО()?

Мне кажется, что с ПолучитьНиО() проблем нет. МаксБаза для всех фирм одинакова, т.е. можно тянуть и из справочника НиО из стандартного элемента ФЗПЕСВ, а сама ставка для ТаблицыЗначений извлекается при помощи ПолучитьСтавку(), а она уже исправлена.

Но все же мне, как и говорила раньше, идея ivisor нравится больше -- универсальная, не требует реструктуризации базы, а с рутиной может справиться и пользователь:

Quote (Zaval)
создала ГБ по инструкции в несколько строк

Хотя, на первый взгляд, кажется более простым решение Max_Nj. Но, в случае изменения ставки в средине месяца, потребует очередного вмешательства, реструктуризация базы усложняет обновление в дальнейшем, требует дополнительного описания проверки на ненулевое значение реквизита ЕСВФирмы (по стандартной посчитает, бухи возрадовались и не проверили).
В общем, на вкус и цвет... Главное, чтобы работало smile

Услуги программиста 1С


#15   ivisor

ivisor

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1438
    • Регистрация: 06-March 08
    • Откуда:Планета Земля

Отправлено 08 February 2011 - 00:15

Еще как вариант можно использовать реквизит "Дополнительно" у налога.
Code
Процедура ДобавитьНиО(Код, Сообщение, СчетЗатрат="")
// ...
     Спис = СоздатьОбъект("СписокЗначений");
     глПарсить(тбНиО.НиО.Дополнительно.Получить(КонецПериода),Спис);
     СтавкаНалога = Число(Спис.Получить(тбНиО.НиО.Код+СокрЛП(Фирма.Код)); // Название доп параметра вносится как КодНалога+КодФирмы
// ...
КонецПроцедуры

Но далее, как и в случае с добавлением периодического реквизита в спр. Фирмы, возникает проблема с изменением функции ПолучитьСтавку(ИмяПараметра) лично мне западло туда лезть biggrin .

Для сравнения - заменяем в ДобавитьНиО(Код, Сообщение, СчетЗатрат="")

Code
    Если Лев(Код,3)="ФЗП" Тогда
      // для отчислений с ФОТ учитываем изменение ставки в середине месяца
      тбНиО.Ставка = ПолучитьСтавку(Код);
     Иначе
      тбНиО.Ставка = тбНиО.НиО.Ставка.Получить(КонецПериода);
     КонецЕсли;

На

Code
Если Лев(Код,3)="ФЗП" Тогда
      // для отчислений с ФОТ учитываем изменение ставки в середине месяца
      // тбНиО.Ставка = ПолучитьСтавку(Код);
                    тбНиО.Ставка = ПолучитьСтавку(Код+СокрЛП(Фирма.Код)); // Код налога для фирмы сформирован как КодНалога+КодФирмы
      //или на
                    тбНиО.Ставка = ПолучитьСтавку(Код+СокрЛП(Фирма.ПрефиксНомера));  // Код налога для фирмы сформирован как КодНалога+КодФирмы
     Иначе
      тбНиО.Ставка = тбНиО.НиО.Ставка.Получить(КонецПериода);
     КонецЕсли;

Изменяется всего одна! строка.
А ставки по каждой фирме так и так вносить и обновлять ручками придется


Кстати меня заинтересовало вот что:

Почему больничный начисляется в корреспонденции с 663 счетом (Дт 652 или СчЗатрат - Кт 663)
А ЕСВ на оплату больничного удерживается в корреспонденции с 661 (Дт 661 - Кт 651)

Почему не с 663 ?! wacko

Code
//глПроводка(Контекст,Подразделение,"65.1",ПроцЕСВБол,"Удержание: единый взнос (больничный),",, Сотрудник,МесяцНачисленияЗП,,НиО,,, ,,"ЗП");
глПроводка(Контекст,СчетДругие,"65.1",ПроцЕСВБол,"Удержание: единый взнос (больничный),",, Сотрудник,МесяцНачисленияЗП,,НиО,,, ,,"ЗП");


#16   5_kopeek

5_kopeek

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 608
    • Регистрация: 31-January 11
    • Откуда:Украина

Отправлено 08 February 2011 - 00:42

Quote (ivisor)
Почему не с 663 ?!

Отличный вопрос!
Напоминает вот это (отчет ЕСВ):
Code
Если глПолучитьНиО(ноЕСВ, "ФЗПЕСВ", "о ставке начислений единого соц.взноса") = 0 Тогда
     Возврат;
     // Добавлено 5_копеек (начало)    
    Иначе
     СтавкаЕСВ = ноЕСВ.Ставка.Получить(КонМесяца(ДатаВМесяце));
     // Добавлено 5_копеек (конец)    
    КонецЕсли;
.........................
    Если (ПлательщикНалогаНаПрибыль = 0) Тогда
      POD_STATUS = "Платник фіксованого податку";
        
     // Изменено 5_копеек (начало)
     //ИначеЕсли глПолучитьНиО(ноСоцСтрах,"ФЗПСоцСтрах","об отчислениях в фонд социального страхования с фонда заработной платы!") <> 0 Тогда
     //СтавкаФСС = ноСоцСтрах.Ставка.Получить(КонМесяца(ДатаВМесяце));     
     //Если (СтавкаФСС = 0) Тогда
     //    POD_STATUS = "Платник фіксованого податку";
     //КонецЕсли;
    ИначеЕсли СтавкаЕСВ = 0 Тогда
      POD_STATUS = "Платник фіксованого податку";
    КонецЕсли;       
     // Изменено 5_копеек (конец)    

Почему ФЗПСоцСтрах в отчете, который ввели после отмены этого налога?

Услуги программиста 1С


#17   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 08 February 2011 - 07:17

Quote (ivisor)
Кстати меня заинтересовало вот что: Почему больничный начисляется в корреспонденции с 663 счетом (Дт 652 или СчЗатрат - Кт 663) А ЕСВ на оплату больничного удерживается в корреспонденции с 661 (Дт 661 - Кт 651)

Ну здесь как женская логика - бессмысленно и беспощадно!!! biggrin
Практически все бухгалтера не используют 663.
А новые правила выплаты больничных - это вобще маразм.
Как разъясняет ФСС(хотя они сами до конца них...я не знают) :
Больничные за счет ФСС нужно выплачивать все (т.е. начисленные), а налоги которые удерживаются - удерживать из суммы других начислений! БРЕД!
  • 1

#18   tttbuh

tttbuh

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 107
    • Регистрация: 04-June 09
    • Откуда: , ,

Отправлено 08 February 2011 - 07:49

В ПУБ_032 в проводках по удерж. ЕСВ (661-651) аналитика по сч.651 есть- "един. соц. внесок", а в проводках по начисл. ЕСВ (821-651) нет. Проверяла на демоверсии. В чем ошибка?
  • 0

#19   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 08 February 2011 - 07:54

Quote (tttbuh)
а в проводках по начисл. ЕСВ (821-651) нет.

т.е. как нет??? У Вас что не начислен ЕСВ на ФОП....
А не смотрели движение по 651 счету?
  • 1

#20   tttbuh

tttbuh

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 107
    • Регистрация: 04-June 09
    • Откуда: , ,

Отправлено 08 February 2011 - 08:26

Начислен, в том-то и вопрос.Разносила банк, проверила оборотку по 651, а там начислено, но без субконто, я, конечно, поправила руками, но пошла проверять в демке. А там тоже самое, значит ошибка не у меня.
  • 0


Обратно в Программирование и конфигурирование 1С Предприятия 7.7

Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных