Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Приходная накладная


  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1   mathd

mathd

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 24-January 11
    • Откуда:Луганск , Луганская Область , Украина

Отправлено 25 January 2011 - 12:01

Здравствуйте, я очень нуждаюсь в вашей помощи, друзья! Я новичок пока что в программировании 1с, и хочу у вас спросить , как правильно изменить авто подсчет в документе приходная накладная, программа считает сумму и НДС автоматически когда указывается кол-во и цена, но мне нужно, чтобы я сам указывал валовую сумму с НДС и кол-во , а программа считала бы НДС и цену сама.
Просмотрел модуль в документе, не хотел бы нарушить целостность, помогите пожалуйста с кодом , что и куда нужно заменить.
Версия 1с Предприятие 7,7 , конфигурация: Бухучет для Украины 7.70.280

Добавлено (25.01.2011, 12:01)
---------------------------------------------
В общем сделал так:

/

Code
/ ===============================
Процедура ПриИзмененииСуммыСНДС()
Если Кво=0 Тогда
Сообщить("Не указано количество!");
Возврат;
КонецЕсли;
СуммаБезНДС = СуммаСНДС*100/(100+НДС);
Количество = Кво*Коэффициент;
Если Количество<>0 Тогда
ЦенаБезНДС = СуммаБезНДС/(Количество);
Иначе
ЦенаБезНДС = СуммаБезНДС/(Кво);
КонецЕсли;
КонецПроцедуры

Процедура ПриИзмененииКоличества()
Если Кво=0 Тогда
Возврат;
КонецЕсли;
Количество = Кво*Коэффициент;
Если Количество<>0 Тогда
ЦенаБезНДС = СуммаБезНДС/(Количество);
Иначе
ЦенаБезНДС = СуммаБезНДС/(Кво);
КонецЕсли;
КонецПроцедуры

Процедура ПриИзмененииЦены()
Количество = Кво*Коэффициент;
СуммаБезНДС = Количество*ЦенаБезНДС;
СуммаСНДС = НДС*СуммаБезНДС/100+СуммаБезНДС;
КонецПроцедуры

Но при вводе суммы без НДС считает только сумму с НДС и НДС, а вот цену не выбивает, у кого какие соображения?

  • 0

#2   Golub____Ka

Golub____Ka

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 72
    • Регистрация: 18-November 09
    • Откуда:Ужгород , Закарпатская Область , Украина

Отправлено 25 January 2011 - 16:21

не в ту вітку попала
  • 0






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных