Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

- - - - -

периодический реквизит


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 2

#1   IRON_PRIEST

IRON_PRIEST

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 38
    • Регистрация: 16-February 10
    • Откуда:Днепропетровск , Днепропетровская Область , Украина

Отправлено 18 January 2011 - 19:05

и снова здравствуйте !

подскажите как узнать является ли реквизит периодическим?

пробно сделал код

Code
Процедура Сформировать()
  Таб=СоздатьОбъект("Таблица");
  вид="Сотрудники";
  Спр=Метаданные.Справочник(вид);
  Для к=1 по спр.Реквизит() Цикл
   ном=спр.Реквизит(к);
   вид=ном.периодический;
   Таб.Вывестисекцию("секция_1");
  КонецЦикла;
  Таб.Показать();
КонецПроцедуры

там где периодический ставится 1

а если вы пишу

Code
Если Ит.Субконто().СчетЗатрат.Периодический=1 Тогда           //|
     СчетЗатратНач=Ит.Субконто().СчетЗатрат.Получить(НачДата); //|
     СчетЗатратКон=Ит.Субконто().СчетЗатрат.Получить(КонДата); //|
    Иначе                    //|счет затрат в БУ
     СчетЗатратНач=Ит.Субконто().СчетЗатрат;                   //|
     СчетЗатратКон=Ит.Субконто().СчетЗатрат;                   //|
    КонецЕсли;

то матюкается Поле агрегатного объекта не обнаружено (Периодический)

  • 0

#2   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 18 January 2011 - 21:56

Quote (IRON_PRIEST)
Если Ит.Субконто().СчетЗатрат.Периодический=1 Тогда

Как может быть Субконто переодическим????
  • 0

#3   IRON_PRIEST

IRON_PRIEST

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 38
    • Регистрация: 16-February 10
    • Откуда:Днепропетровск , Днепропетровская Область , Украина

Отправлено 18 January 2011 - 23:11

черт его знает. а каким образом можно прилепить проверку на периодический реквизит к субконто?
  • 0


Обратно в 1С Бухгалтерия 7.7 для Украины

Похожие темы




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных