Перейти к содержимому

Перейти
Перейти

помогите исправить ошибку


  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1   Альбина Гайзетдинова

Альбина Гайзетдинова

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 10-April 18

Отправлено 10 April 2018 - 13:22

В коде ошибка
{WebСервис.WebОбмен.Модуль(33,20)}: Тип не определен (ЧтениеХML)
 ЧтениеXML = Новый <<?>>ЧтениеХML; (Проверка: Сервер)
Вот код
 
Процедура ЗарегистрироватьИзмененияДанных(УзелОбмена) Экспорт
СоставПланаОбмена = УзелОбмена.Метаданные().Состав;
Для Каждого ЭлементСоставаПланаОбмена Из СоставПланаОбмена Цикл
ПланыОбмена.ЗарегистрироватьИзменения(УзелОбмена,ЭлементСоставаПланаОбмена.Метаданные);
КонецЦикла
КонецПроцедуры
 
Функция ВыполнитьОбмен(КодУстройства, ДанныеУстройства)
УстановитьПривилегированныйРежим(Истина);
 
//1. Инициализация (если нужно)
УзелОбмена = ПланыОбмена.Мобильные.ЭтотУзел().ПолучитьОбъект();
Если НЕ ЗначениеЗаполнено(УзелОбмена.Код) Тогда
УзелОбмена.Код="001";
УзелОбмена.Наименование="Центральный";
УзелОбмена.Записать();
КонецЕсли;
 
 
УзелОбмена=ПланыОбмена.Мобильные.НайтиПоКоду(КодУстройства);
Если УзелОбмена.Пустая() Тогда
НовыйУзел=ПланыОбмена.Мобильные.СоздатьУзел();
НовыйУзел.Код=КодУстройства;
НовыйУзел.Наименование = КодУстройства;
НовыйУзел.Записать();
ЗарегистрироватьИзмененияДанных(НовыйУзел.Ссылка);
УзелОбмена = НовыйУзел.Ссылка;
 КонецЕсли;
 
 //2.Получение данных из мобильного устройства
 УзелОбмена = ПланыОбмена.Мобильные.НайтиПоКоду(КодУстройства);
 Сообщить(КодУстройства);
 ЧтениеXML = Новый ЧтениеХML;
 ЧтениеXML.УстановитьСтроку(ДанныеУстройства.Получить());
 ЧтениеСообщения=ПланыОбмена.СоздатьЧтениеСообщения();
 ЧтениеСообщения.НачатьЧтение(ЧтениеXML);
 ПланыОбмена.УдалитьРегистрациюИзменений(ЧтениеСообщения.Отправитель.ЧтениеСообщения.НомерПринятого);
 НачатьТранзакцию();
 Пока ВозможностьЧтенияXML (ЧтениеXML) Цикл
Данные = ПрочитатьXML(ЧтениеXML);
Если НЕ Данные = Неопределено Тогда
Данные.ОбменДанными.Отправитель=ЧтениеСообщения.Отправитель;
Данные.ОбменДанными.Загрузка=Истина;
Данные.Записать();
КонецЕсли;
 КонецЦикла;
 ЗафиксироватьТранзакцию();
 ЧтениеСообщения.ЗакончитьЧтение();
 ЧтениеXML.Закрыть();
 
 //3. Выгрузка данных в мобильное устройство
 УзелОбмена=ПланыОбмена.Мобильные.НайтиПоКоду(Кодустройства);
 ЗаписьXML=Новый ЗаписьXML;
 ЗаписьXML.УстановитьСтроку("UTF-8");
 ЗаписьXML.ЗаписатьОбъявлениеXML();
 ЗаписьСообщения.НачатьЗапись(ЗаписьXML,УзелОбмена);
 ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xsi" "http://www.w3.org/20...ema-instance");
 ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("v8", "http://v8/1c.ru/data");
 ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(УзелОбмена, ЗаписьСообщения.НомерСообщения);
 Пока ВыборкаИзменений.Следующий()Цикл
Данные=ВыборкаИзменений.Получить();
ЗаписатьXML(ЗаписьXML,Данные);//Записать данные в сообщение
 КонецЦикла;
 ЗаписьСообщения.ЗакончитьЗапись();
 Возврат Новый ХранилищеЗначения (ЗаписьXML.Закрыть(), Новый СжатиеДанных (9));
 
 КонецФункции //ВыполнениеОбмена
 

  • 0

#2   Алёна Люндина

Алёна Люндина

      Рядовой

    • Пользователи
    • Сообщений: 4
    • Регистрация: 13-April 18

Отправлено 13 April 2018 - 13:49

поменяй местами 15 и 16 строки


  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных