Перейти к содержимому

Перейти
Перейти

Работа в макете


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 7

#1   dir_85

dir_85

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 24-November 17

Отправлено 24 November 2017 - 14:14

Как в макете 8.3 в определенной ячейке сложить значения других ячеек. Через шаблон не получается [Значение1+Значение2].


  • 0

#2   Андрей Федотов

Андрей Федотов

      Рядовой

    • Пользователи
    • Сообщений: 5
    • Регистрация: 22-July 16
    • Откуда:Москва

Отправлено 03 January 2018 - 12:09

Не понял) Пример макета и кода в студию. 


  • 0

С уважением,

Андрей Федотов

Future IT Solutions


#3   Ксения Рачилова

Ксения Рачилова

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 03-February 18

Отправлено 03 February 2018 - 16:39

никак. в коде складывать


  • 0

#4   irinus@yandex.ru

irinus@yandex.ru

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 14-February 18

Отправлено 14 February 2018 - 07:52

только в коде , в макет только параметр передается


  • 0

#5   Михаил Курятников

Михаил Курятников

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 24-December 14

Отправлено 20 March 2018 - 11:22

Как в макете 8.3 в определенной ячейке сложить значения других ячеек. Через шаблон не получается [Значение1+Значение2].Только в коде, в макет выводятся только параметры.


  • 0

#6   Spirit

Spirit

      Рядовой

    • Пользователи
    • Сообщений: 4
    • Регистрация: 08-June 18

Отправлено 08 June 2018 - 10:32

Макет - это не Ексель, такого нет. Можете Сделать шаблон [парам1] какой- то текст [парам1]. Если нужно происходили арифметические операции, то только кодом.


  • 0

#7   Vladimir_877

Vladimir_877

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 07-June 18

Отправлено 13 June 2018 - 07:00

Функция ВычислитьСуммуВыделенныхЯчеекТабличногоДокумента(ПолеТабличногоДокумента) Экспорт

Сумма = 0;
Для Каждого Область Из ПолеТабличногоДокумента.ВыделенныеОбласти Цикл
Если ТипЗнч(Область) = Тип("ОбластьЯчеекТабличногоДокумента") Тогда
Для ИндексСтрока = Область.Верх По Область.Низ Цикл
Для ИндексКолонка = Область.Лево По Область.Право Цикл
Попытка
Сумма = Сумма + Число(СтрЗаменить(ПолеТабличногоДокумента.Область("R" + Формат(ИндексСтрока, "ЧГ=0") + "C" + Формат(ИндексКолонка, "ЧГ=0")) .Текст, " ", ""));
Исключение
КонецПопытки;
КонецЦикла;
КонецЦикла;
КонецЕсли;
КонецЦикла;

Возврат Сумма;

КонецФункции


  • 0

#8   elnino

elnino

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 06-August 18

Отправлено 06 August 2018 - 17:44

спс


  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных