Перейти к содержимому

Перейти
Перейти

Округление. Помогите, пожалуйста


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 3

#1   Ivasishinav

Ivasishinav

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 03-July 17

Отправлено 03 July 2017 - 11:31

Добрый день!
Может подскажите, в 1с 7.7 редакция 4.5 Мисофт никак не получается сделать, чтобы счет-фактура не округляла до целого числа НДС и Сумму. Два дня почти везде менял разрядность - все без толку. В модуле это изменить не получается. Может подскажите волшебную строчку? =)
c6e81f6c18a8aec8fcd6ea7b35bc6866.jpeg
 
Код:
 

ИначеЕсли (ИмяРеквизита = "Количество"icon_wink.gif Тогда
Сумма = ОКР((Цена*Количество),ОКРУГЛЕНИЕ,1);
РассчитатьНалоги();
Всего = глПоказательДокумента(Контекст, "СуммаСНалогами"icon_wink.gif;
ИначеЕсли (ИмяРеквизита = "Цена"icon_wink.gif Тогда
Сумма = ОКР((Цена*Количество),ОКРУГЛЕНИЕ,1);
РассчитатьНалоги();

 

 

Меняю во 2 и 6 строке слово округление на 2 и ничего не меняется

есть еще в конце модуля процедура самого округления, может ее как-то изменить?

 

 

Процедура Округление()
Если ПустоеЗначение(ОкруглятьДо) = 1 Тогда
Сообщить("Не задан способ округления"icon_wink.gif;
Возврат;
КонецЕсли;

ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
СпособОкргления = ОкруглятьДо;
Округление = Число(СокрЛП(Строка(СпособОкргления)));
п = Цена - Цел(Цена/Округление)*Округление;
Если (п < Округление/2) Тогда
Цена= Цел(Цена/Округление)*Округление;
ИначеЕсли (Округление/2 <= п) и (п < (Округление/2+Округление)) Тогда
Цена = Цел(Цена/Округление)*Округление + Округление;
ИначеЕсли (п >= (Округление/2+Округление)) Тогда
Цена = Цел(Цена/Округление)*Округление + Округление*2;
КонецЕсли;
Пересчет("Цена"icon_wink.gif;
КонецЦикла;
КонецПроцедуры

 

 

 

Процедура РассчитатьНалоги()

 
НДС = глПоказательДокумента(Контекст, "НДС");
НП = глПоказательДокумента(Контекст, "НП");
Всего = глПоказательДокумента(Контекст, "СуммаСНалогами");
Форма.НДС.Видимость(глПризнакУчетаНалога(Контекст, "НДС"));
//Форма.НП.Видимость(глПризнакУчетаНалога(Контекст, "НП"));
 
КонецПроцедуры // РассчитатьНалоги()

 


Сообщение отредактировал Ivasishinav: 03 July 2017 - 11:36

  • 0

#2   hvv2002

hvv2002

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 22-December 15

Отправлено 29 September 2017 - 15:13

Посмотритев самой печатной форме может стоять формула типа такого : МнЧ.АкцизЦена#Ч010.2


  • 1

#3   uralmaks

uralmaks

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 30-April 18

Отправлено 30 April 2018 - 09:50

Спасибо

 


  • 0

#4   muller2306

muller2306

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 02-September 14

Отправлено 10 May 2018 - 11:07

Посмотрите, какая функция указана в ячейках таблицы в конфигураторе. Вот в ней и нужно менять. Там не  "МнЧ.АкцизЦена#Ч010.2" - ибо это просто формат числа, у Вас 2 знака после запятой есть, тут точно округляет, а не форматирует.


  • 0






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных