Перейти к содержимому

Перейти
Перейти

Свертка базы 1с 7.7 не типовая конфигурация


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 2

#1   san4esnet

san4esnet

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 16-December 16

Отправлено 16 December 2016 - 06:47

Добрый день уважаемые пользователи .   кто подскажет как перенести  вторые цены (розничную) 

 есть оброботка ЗавершениеПериода  порядок свертки  идет ПереносУчетКредитаПостовщика потом ПереносВзаиморасчеты потом ПереносКассы потом переносОстаткиТоваров

 

вот часть кода переноса остатков из ЗавершениеПериода

//-------------------------
Функция ЗаполнитьОстаткиТоваров()
	Докум=СоздатьОбъект("Документ.ПереносОстаткиТоваров");
	Докум.АвтоВремяКонецДня();
	
	Запрос=СоздатьОбъект("Запрос");
	ТекстЗапроса=
	"//{{ЗАПРОС(ОстаткиТоваров)
	|Период с '01.01.1990' по ДатаКонцаПериода;
	|Обрабатывать НеПомеченныеНаУдаление;
	|Товар = Регистр.ОстаткиТоваров.Товар;
	|Склад = Регистр.ОстаткиТоваров.Склад;
	|Ден = Регистр.ОстаткиТоваров.БазоваяСтоимость;
	|Вал = Регистр.ОстаткиТоваров.ВалютнаяСтоимость; 
        |Розн_Цена = Регистр.ОстаткиТоваров.Товар.Розн_Цена;
	|Тов = Регистр.ОстаткиТоваров.ОстатокТовара;
	|Группировка Товар упорядочить по Товар.Наименование без групп;
	|Группировка Склад упорядочить по Склад.Наименование без групп;
	|Функция ОстатокДен = КонОст(Ден);
	|Функция ОстатокВал = КонОст(Вал);
	|Функция ОстатокТов = КонОст(Тов); 
	|Функция ОстатокРозн_Цена = КонОст(Розн_Цена);
	|"//}}ЗАПРОС
	;
	Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда 
		Предупреждение("Системная ошибка выполнения запроса по Регистр.ОстаткиТоваров!"); 
		Возврат 1; 
	КонецЕсли;

вот выделил то что добавил Функция ОстатокРозн_Цена = КонОст(Розн_Цена);

 

стал дергать цену вторую создается документ там появилась вторая цена ,но делаю остаток по вторым ценам цена пишет 0 . почему то не переноситься 2 цена . первая цена закупки переноситься нормально .

вот код ПереносОстаткиТоваров

// ********************
Процедура ОбработкаПроведения(Режим)
	ВыбратьСтроки();
	Пока ПолучитьСтроку()=1 Цикл
		Регистр.ОстаткиТоваров.ПривязыватьСтроку(НомерСтроки);
		Если ОстатокТовара>=0 Тогда
			Регистр.ОстаткиТоваров.ДвижениеПриход(Товар,Склад,БазоваяСтоимость,ВалютнаяСтоимость,ОстатокТовара,ФлагУчета); 
	
		Иначе		    
			Регистр.ОстаткиТоваров.ДвижениеРасход(Товар,Склад,-БазоваяСтоимость,-ВалютнаяСтоимость,-ОстатокТовара,ФлагУчета);  
		КонецЕсли;  
		КонецЦикла;
КонецПроцедуры

может кто подсказать что забыл еще добавить чтоб вторая цена тоже переносилась Розничная цена


  • 1

#2   Алексей Максимов

Алексей Максимов

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 03-February 17

Отправлено 03 February 2017 - 04:53

при проведении документа смотрите какие движения он делает, в них и надо добавить движения по заполнению нужного регистра вашими ценами


  • 0

#3   Boris_1c

Boris_1c

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 17-April 17

Отправлено 17 April 2017 - 10:34

су по куску кода "Регистр.ОстаткиТоваров.Товар.Розн_Цена" - цена хранится в справочнике, и реквизит не периодический. Цены и так сохранятся. А по периносу остатков регистровых, есть универсальные процедуры..


  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных