Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Как при печати Счета выводить автора?


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 4

#1   alexabv

alexabv

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 24
    • Регистрация: 12-April 10
    • Откуда: , ,

Отправлено 27 December 2010 - 14:21

Как при печати Счета выводить автора? 1С.Предприятие 7.7 (сетевая версия) 7.70.025?
Пробовал добавить в Форма-Документ. Счет (Счет-фактура) Форма - Таблица_Укр
<Справочник.Пользователи>

http://abvstroy.at.u...a-tablica_u.jpg

выдает ошибку http://abvstroy.at.u...polzovateli.jpg

Переменная не определена (Справочник)
Справочник<<?>>.Пользователи

Что не так делаю?

  • 0

#2   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 27 December 2010 - 14:46

Quote
Что не так делаю?

Занимаешся 1С.
Quote
Пробовал добавить в Форма-Документ. Счет (Счет-фактура) Форма - Таблица_Укр
<Справочник.Пользователи>

Читай книжку по конфигурации.

Добавлено (27.12.2010, 14:44)
---------------------------------------------
Такой вопрос можно задать только если вообще не понимать что пишеш. angry

Добавлено (27.12.2010, 14:46)
---------------------------------------------
1. Автор - общий реквизит для всех документов.
2. Для его фиксации необходимо заполнять справочник "Пользователи".
При выводе на печать необходимо всего лишь написать "ХХХ.Автор" или "СокрЛП(ХХХ.Автор.Наименование)"
где ХХХ - это документ.
ВСЕ!!!!!

  • 0

#3   alexabv

alexabv

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 24
    • Регистрация: 12-April 10
    • Откуда: , ,

Отправлено 27 December 2010 - 15:35

Супер. Получилось. А как теперь в Диалоге
http://abvstroy.at.u...orma-dialog.jpg

добавить

показать/скрыть автора и установить типо галочку (вкл/выкл)?

И самое главное
чтобы выполнялось условие:
если галочка вкл - то выводить Автор
если галочка выкл - то не выводить Автор

  • 0

#4   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 27 December 2010 - 15:45

Блин, отвечаю только потому, что есть свободное время.
1. Выносиш на форму флажок с идентификатором, например, "фПечатьАвтора", без кавичек cool
2. В модуле (в процедуре "Печать" наверно) обьявляеш переменную (в начале текста процедуры)
Процедура Печать()
Перем ИмяАвтора;

КонецПроцедуры
3. Делаешь условие:
Процедура Печать()
Перем ИмяАвтора;

Если фПечатьАвтора = 1 Тогда
ИмяАвтора = Автор;
КонецЕсли;

КонецПроцедуры
4. И самое важное deal В Печатной форме, где у тебя выводится автор пишешь вместо "Автор", "ИмяАвтора"
5. ЧИТАЙ КНИЖКУ book

Добавлено (27.12.2010, 15:45)
---------------------------------------------
И еще, спасибо не надо, + хватит

  • 0

#5   alexabv

alexabv

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 24
    • Регистрация: 12-April 10
    • Откуда: , ,

Отправлено 28 December 2010 - 09:13

Спасибо справился.

Есть еще другие задачи, с которыми справиться наверное не смогу. Хотим организовать управленческий учет приспособленный для нашего предприятия. Задачу сразу не напишу. Надо время. Есть какие-либо готовые решения, чтобы иметь представление о том что же есть?

  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных