Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

8.1 выгрузить данные справочника в иерархии "Физические лица


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 5

#1   solare

solare

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 57
    • Регистрация: 19-January 09
    • Откуда: , ,

Отправлено 23 December 2010 - 16:34

Помогите пожалуйста. Мне нужно выгрузить данные справочника в иерархии "Физические лица" в другую версию конфигурации 8.1. Стандартной обработкой не получится, хотел написать руками.
Вы бы не могли мне помочь примером кода выгрузки справочника напимер в фал "Выгрузка" на с:\\ Очень нужен пример кода, остальное я по аналогии (реквизиты) допишу. Помогите пожалуйста.
Я понимаю, что нужно создать файл, найти по владельцу, если это группа и т.д. Но вот с правильным написание кода никак.
я всегда использовал стандартные обработки выгрузки в эдентичную конфигурацию и горя не знал, а сейчас обновился и даже не знаю с чего начать. Не могли бы вы помочь мне примером синтаксиса с самого начала.

Добавлено (23.12.2010, 15:35)
---------------------------------------------
мне нужно что-то типа этого, но полсностью справочник в иерархии

Процедура КнопкаВыгрузитьНажатие(Кнопка)
ПутьКФайлу = "D:\Vigruzka_"+Формат(ТекущаяДата(),"ДФ=YYYYMMdd")+".xml";
Запись = Новый ЗаписьXML;
Запись.ОткрытьФайл(ПутьКФайлу, "UTF-8");
Запись.ЗаписатьОбъявлениеXML(); //<?xml version="1.0" encoding="UTF-8"?>
Запись.ЗаписатьНачалоЭлемента("orgstructure");
Запрос = Новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ
| РаботникиОрганизацийСрезПоследних.Сотрудник,
| РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
| РаботникиОрганизацийСрезПоследних.Должность,
| РаботникиОрганизацийСрезПоследних.Период,
| РаботникиОрганизац ийСрезПоследних.ПодразделениеОрганизации.Порядок КАК ПодразделениеОрганизацииПорядок,
| РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
|ИЗ
| РегистрСведений.РаботникиОрганизаций .СрезПоследних(&dateper, ) КАК РаботникиОрганизацийСрезПоследних
|
|УПОРЯДОЧИТЬ ПО
| ПодразделениеОрганизацииПорядок
|ИТОГИ ПО
| ПодразделениеОрганизации ИЕРАРХИЯ
|АВТОУПОРЯДОЧИВАНИЕ
|";
Запрос.УстановитьПараметр("dateper", ТекущаяДата());
Результат = Запрос.Выполнить();
Дерево = Результат.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
ОбойтиУровеньДерева(Дерево.Строки, Запись);
Запись.ЗаписатьКонецЭлемента();
Запись.Закрыть();
КонецПроцедуры

Добавлено (23.12.2010, 16:34)
---------------------------------------------
а вот и пример процедуры:ОбойтиУровеньДерева(Строки, Запись)

Процедура ОбойтиУровеньДерева(Строки, Запись)
Для каждого Строка из Строки Цикл
Если ПустаяСтрока(Строка(Строка.Сотрудник)) Тогда
Запись.ЗаписатьНачалоЭлемента("department");
Запись.ЗаписатьАтрибут("dep_id", Строка(Строка.ПодразделениеОрганизации.УникальныйИдентификатор()));
Запись.ЗаписатьАтрибут("dep_name", Строка(Строка.ПодразделениеОрганизации));
Запись.ЗаписатьАтрибут("dep_code", СокрЛП(Строка(Строка.ПодразделениеОрганизации.Код)));
ОбойтиУровеньДерева(Строка.Строки, Запись);
Запись.ЗаписатьКонецЭлемента();
Иначе
Запись.ЗаписатьНачалоЭлемента("orgposition");
Запись.ЗаписатьАтрибут("user_id", Строка(Строка.Сотрудник.УникальныйИдентификатор()));
Запись.ЗаписатьАтрибут("user_position_id", Строка(Строка.Должность.УникальныйИдентификатор()));
Запись.ЗаписатьАтрибут("user_position", Строка(Строка.Должность));
Запись.ЗаписатьАтрибут("user_is_active", ?(Строка.ПричинаИзмененияСостояния = Перечисления.ПричиныИзмененияСостояния.Увольнение,"0","1"));
ОбойтиУровеньДерева(Строка.Строки, Запись);
Запись.ЗаписатьКонецЭлемента();
КонецЕсли
КонецЦикла;
КонецПроцедуры

Помогите пожалуйста сделать выгрузку в иерархии всего справочника

  • 0

#2   Ardi

Ardi

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 958
    • Регистрация: 27-January 09
    • Откуда:Столица

Отправлено 23 December 2010 - 18:32

Quote (solare)
а сейчас обновился и даже не знаю с чего начать.

Если конфигурация одинаковая, но разные релизы - то должно работать старое. Разве нет?
  • 0

#3   KristinaZgerskaya

KristinaZgerskaya

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 23-May 14

Отправлено 23 May 2014 - 07:30

Можно поискать обработку для выгрузки,есть на диске ИТС такая,можно выбрать файлы которые вам нужны и выгрузить


  • 0

#4   ant8

ant8

      Рядовой

    • Пользователи
    • Сообщений: 4
    • Регистрация: 10-June 14

Отправлено 10 June 2014 - 08:08

Может проще конвертацией данных?


  • 0

#5   electricdex

electricdex

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 10-June 14

Отправлено 10 June 2014 - 10:20

Если конвертацией данных то можно даже в поле родитель изменить структуру папок так как это требуется

 


  • 0

#6   crayzz

crayzz

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 05-October 15

Отправлено 05 October 2015 - 23:24

Чтоб не изобретать велосипед возьми сделай правила полной конвертации и выгружай справочники, документы и тд.


  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных