Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

1C Акт сверки


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 10

#1   DiMix

DiMix

      Рядовой

    • Пользователи
    • Сообщений: 7
    • Регистрация: 22-December 10
    • Откуда: , ,

Отправлено 22 December 2010 - 14:51

Добрый день. Может что подскажете. На рисунке Акт сверки. в него попадают все суммы проводок для выбранного контрагента за период по счетам 60.1, 60.2, 62.1. формируется таблица значений куда заносится название документа/операции и сумма проводки. в конце столбец суммируется по дебету, далее вычитается кредит и +-Сальдо на начало. Получается сумма под номером 1 на рисунке. Сумма под номером 2 получается из бух. запроса по этому же контрагенту за эту же дату, по тем же счетам. Далее получаем сумму под номером 2 функцией
Code
   
Пока БИ. ПолучитьСчет(,)=1 Цикл
  Если Би.счет.код <> "62.0" тогда
   СальдоНач =СальдоНач+ БИ.СНД() - БИ.СНК();
   СальдоКон =СальдоКон+ БИ.СКД() - БИ.СКК();
  КонецЕсли;
КонецЦикла;

Насколько я понимаю суммы должны быть равные.

Code
http://www.fotohost.by/pic_s/10/12/22/8961824a75eb1baaf5ac74bca456c627.png

  • 0

#2   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 22 December 2010 - 16:12

А что за счета странные как для акта сверки?
Какая конфигурация?

И рисунок, что-то не открывается(((

  • 0

#3   дщпшые

дщпшые

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 394
    • Регистрация: 13-June 09
    • Откуда:, , Украина

Отправлено 22 December 2010 - 16:21

Quote (Max_Nj)
А что за счета странные как для акта сверки?
Какая конфигурация?

Беларусская конфа ))
  • 0

#4   DiMix

DiMix

      Рядовой

    • Пользователи
    • Сообщений: 7
    • Регистрация: 22-December 10
    • Откуда: , ,

Отправлено 22 December 2010 - 16:29

Code
http://savepic.org/1012773.png

Да, беларусская.

60.1 Расчеты с пост. в руб.
60.2 Расчеты с субподрядчиками
62.1 Расчеты с покуп. в руб.

  • 0

#5   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 22 December 2010 - 16:33

DiMix, А что за счет 62,0
Би.счет.код <> "62.0"
  • 0

#6   DiMix

DiMix

      Рядовой

    • Пользователи
    • Сообщений: 7
    • Регистрация: 22-December 10
    • Откуда: , ,

Отправлено 23 December 2010 - 08:08

62.0 Расчеты с покупателями и заказчиками
  • 0

#7   DiMix

DiMix

      Рядовой

    • Пользователи
    • Сообщений: 7
    • Регистрация: 22-December 10
    • Откуда: , ,

Отправлено 23 December 2010 - 10:40

//СписокВыбранныхСчетов1 = ",60,62"
БИ = СоздатьОбъект("БухгалтерскиеИтоги");
Если ПустоеЗначение(Контрагент) = 0 тогда
БИ.ИспользоватьСубконто(ВидыСубконто.Контрагенты, Контрагент);
Если ПустоеЗначение(Договор)=0 Тогда
БИ.ИспользоватьСубконто(ВидыСубконто.Договоры, Договор);
Иначе
БИ.ИспользоватьСубконто(ВидыСубконто.Договоры,,3);
КонецЕсли;
БИ.ВключатьСубсчета(0, 0);
БИ.ВыполнитьЗапрос(НачДата, КонДата,СписокВыбранныхСчетов1);
БИ. ВыбратьСчета(,,,);
СальдоНач=0;
СальдоКон=0;
Пока БИ. ПолучитьСчет(,)=1 Цикл
Если Би.счет.код <> "62.0" тогда
СальдоНач =СальдоНач+ БИ.СНД() - БИ.СНК();
СальдоКон =СальдоКон+ БИ.СКД() - БИ.СКК();
КонецЕсли;
КонецЦикла; //Пока БИ. ПолучитьСчет(,)=1 Цикл
КонецЕсли;// Если ПустоеЗначение(Котнтрагент) = 0 тогда
  • 0

#8   Max_Nj

Max_Nj

      Ищу работу!!!

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 506
    • Регистрация: 07-August 08
    • Откуда:Мелитополь

Отправлено 23 December 2010 - 12:15

DiMix, Попробуй:
БИ.ВключатьСубсчета(1, 0);
  • 0

#9   DiMix

DiMix

      Рядовой

    • Пользователи
    • Сообщений: 7
    • Регистрация: 22-December 10
    • Откуда: , ,

Отправлено 23 December 2010 - 16:01

СписокВыбранныхСчетов1 = ",60,62"
он чуть выше указывается
  • 0

#10   DiMix

DiMix

      Рядовой

    • Пользователи
    • Сообщений: 7
    • Регистрация: 22-December 10
    • Откуда: , ,

Отправлено 24 December 2010 - 11:04

комментарий я поставил для информации.

вот по этим есть движение:

60.1 Расчеты с пост. в руб.
60.2 Расчеты с субподрядчиками
62.1 Расчеты с покуп. в руб.

Code
http://savepic.org/1017689.png

контрагент есть, просто затёр)

  • 0

#11   DiMix

DiMix

      Рядовой

    • Пользователи
    • Сообщений: 7
    • Регистрация: 22-December 10
    • Откуда: , ,

Отправлено 24 December 2010 - 12:40

сумма 1 рассчитывается исходя из таблицы значений а вторая берется из бух итогов. да, вероятно проблема в ней, в сумме 1.
спс за советы)
без исходников сложно чем то помочь) тем более в моем случае) т.к. проблема плавающая)) в большинстве случаев отчет работает как следует.
  • 0


Обратно в Программирование и конфигурирование 1С Предприятия 7.7

Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных