Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Анализ НДС


  • Авторизуйтесь для ответа в теме
В этой теме нет ответов

#1   vadim007

vadim007

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 146
    • Регистрация: 14-October 09
    • Откуда:Донецк, Украина

Отправлено 25 November 2010 - 11:58

Обратил внимание, что в отчет Анализ НДС попадают непроведенные документы. Посмотрел код отчета - все как положено: указано в запросе "ОбрабатыватьДокументы Проведенные". Протестировал базу - все в норме. В чем может быть причина?

Добавлено (25.11.2010, 11:41)
---------------------------------------------
Ошибка это или нет - исправил это недоразумение в процедуре СформироватьПоПоставщикам(). Исправления отмечены комментарием //!
Пока Запр.Группировка("Дог") = 1 Цикл
ОсталосьСНДС = Запр.СНДС_НУ - Запр.ВыписаноСНДС;
ОсталосьНДС = Запр.НДС_НУ - Запр.ВыписаноНДС;
Т.ВывестиСекцию("Договор");
Пока Запр.Группировка("Ста") = 1 Цикл
ОсталосьСНДС = Запр.СНДС_НУ - Запр.ВыписаноСНДС;
ОсталосьНДС = Запр.НДС_НУ - Запр.ВыписаноНДС;
Т.ВывестиСекцию("СтавкаНДС");
Пока Запр.Группировка("Счет") = 1 Цикл
//! 25.11.2010
Если Запр.Счет.ПометкаУдаления() = 1 Тогда
Продолжить;
КонецЕсли;
Если Запр.Счет.Проведен() = 0 Тогда
Продолжить;
КонецЕсли;
//! Конец вставки
ОсталосьСНДС = Запр.СНДС_НУ - Запр.ВыписаноСНДС;
ОсталосьНДС = Запр.НДС_НУ - Запр.ВыписаноНДС;
текСекц = Т.ПолучитьСекцию("Счет");
текОбл = текСекц.ОсталосьСчет;
Если ПустоеЗначение(Запр.Счет) = 1 Тогда
ИначеЕсли (ОсталосьСНДС < 0) или (ОсталосьНДС < 0) Тогда
// выписано больше чем требуется - красным
текОбл.ЦветТекста(Красный);
ИначеЕсли (ОсталосьСНДС <> 0) или (ОсталосьНДС <> 0) Тогда
// выписано меньше - зеленым
текОбл.ЦветТекста(Зеленый);
КонецЕсли;
Т.ВывестиСекцию(текСекц);
Если фДоДокумента = 1 Тогда
// детально до каждого родительского документа
Пока Запр.Группировка("ТекДок") = 1 Цикл
//! 25.11.2010
Если Запр.ТекДок.ПометкаУдаления() = 1 Тогда
Продолжить;
КонецЕсли;
Если Запр.ТекДок.Проведен() = 0 Тогда
Продолжить;
КонецЕсли;
//! Конец вставки
Если (Запр.СНДС_НУ = 0) и (Запр.НДС_НУ = 0) и (Запр.ВыписаноСНДС = 0) и (Запр.ВыписаноНДС = 0) Тогда
Продолжить;
КонецЕсли;
Т.ВывестиСекцию("ТекущийДокумент");
КонецЦикла; // текущий документ
КонецЕсли;
КонецЦикла; // документ кредита
КонецЦикла; // ставка НДС
КонецЦикла; // договор

Добавлено (25.11.2010, 11:58)
---------------------------------------------
Что-то непонятное: документы непроведенные или удаленные теперь не включаются в отчет, но их суммы все равно входят в итоги!
Где-же собака порылась?

  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных