Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Запрос по документах і строках таб. част.


  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1   Lighta

Lighta

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 71
    • Регистрация: 04-March 10
    • Откуда:Ровно , Ровенская Область , Украина

Отправлено 28 October 2010 - 11:45

Суть питання така - є запрос, відбирає потрібні документи і строки з табл. частини по ньому, він не працює, коли одне з групувань убираю працює, тобто або вибирає документи, або вибирає строки з останього по даті доумента а не з усіх, вродіби групіровки правильно написані, спочатку документ группує потім строкі, що не так?
Code
Запрос = СоздатьОбъект("Запрос");
         
     ТекстЗапроса =     
     "//{{ЗАПРОС(ВыборНакладной)
     |Период с (ДобавитьМесяц(ДатаДок,-1)) по (ДатаДок);
     |ОбрабатыватьДокументы Все;     
     |Обрабатывать НеПомеченныеНаУдаление;
     |Без итогов;
     |Квитанция = Документ.Накладная.ТекущийДокумент;
     |Распоряжение = Документ.Накладная.Распоряжение;
     |Отправлен = Документ.Накладная.Отправлен;
     |Накладная = Документ.Накладная.Номер;
     |Нетто = Документ.Накладная.Нетто;
     |Группировка Квитанция;
     |Группировка СтрокаДокумента;
     |Условие(Распоряжение = ВТД);
     |Условие (Отправлен = 0);
     |"//}}ЗАПРОС
     ;
         
     Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
     КонецЕсли;
         
     Пока Запрос.Группировка(1) = 1 Цикл
      Пока Запрос.Группировка(2) = 1 Цикл
                КонецЦикла;
               КонецЦикла;

Добавлено (28.10.2010, 12:45)
---------------------------------------------
Вирішилась проблема перестановкою в запросі, спочатку умов а потім групувань і відкоментуванням Без Итогов. Хм а яка різниця? Так просто цікаво?

  • 0

#2   igmig65

igmig65

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 516
    • Регистрация: 05-July 07
    • Откуда: , ,

Отправлено 28 October 2010 - 11:46

Уберите "Без итогов"
вообще запрос некорректен.
  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных