Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Колонка с пиктограмой


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 2

#1   siniypank

siniypank

      Майор

    • Пользователи
    • PipPipPipPip
    • Сообщений: 84
    • Регистрация: 06-July 09
    • Откуда:Киев , Киев , Украина

Отправлено 22 October 2010 - 17:47

Добрый вечер. конфигурация бух учет. Создал в журнале новую колонку, прописал формулу и вот такую функцию:

Функция НомерПиктограммы()
Перем НомерПикт;
НомерПикт = 2;
Если ТекущийДокумент.Выбран () = 1 Тогда
ПодчДок = СоздатьОбъект ("Документ");
ПодчДок =ВыбратьПодчиненныеДокументы (`01.01.1980`,`01.12.2100`, ТекущийДокумент);
Пока ПодчДок.ПолучитьДокумент () = 1 Цикл
Если ПодчДок.Вид () = "НалоговаяНакладная" Тогда
НомерПикт = 1;
КонецЕсли;
Прервать;
КонецЦикла;
КонецЕсли;
Возврат НомерПикт;
КонецФункции

И в конечном итоге пиктограммы не проставляет

  • 0

#2   AgA

AgA

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 276
    • Регистрация: 07-November 09
    • Откуда:Харьков , Харьковская Область , Украина

Отправлено 22 October 2010 - 18:18

Скажите а в свойствах табличной части какая картинка.
Нажмите на свойства табличной части, на закладке картинка, должна быть картинка.
Количество должно быть 2.
Quote (siniypank)
НомерПикт = 2;

Скорее всего у вас нет пиктограммы.

пример можете посмотреть например в торговле. в журнале расходные накладные.

  • 0

#3   siniypank

siniypank

      Майор

    • Пользователи
    • PipPipPipPip
    • Сообщений: 84
    • Регистрация: 06-July 09
    • Откуда:Киев , Киев , Украина

Отправлено 22 October 2010 - 18:39

Quote (AgA)
Скорее всего у вас нет пиктограммы.

пример можете посмотреть например в торговле. в журнале расходные накладные.

Спасибо не внимателен, просто прицепился к полю текста и все, а оно в свойствах многострочной части. +

  • 0



Похожие темы




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных