Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

В Отчете по ТМЦ не показывает движение производства Помогите


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 2

#1   инуля

инуля

      Рядовой

    • Пользователи
    • Сообщений: 16
    • Регистрация: 18-June 09
    • Откуда:Кременчуг , Полтавская Область , Украина

Отправлено 01 October 2010 - 14:29

БИ=СоздатьОбъект("БухгалтерскиеИтоги");
Если ВыбСклад.Выбран()=1 Тогда
БИ.ИспользоватьСубконто(ВидыСубконто.МестаХранения,ВыбСклад,2);
Иначе
БИ.ИспользоватьСубконто(ВидыСубконто.МестаХранения,,1);
КонецЕсли;
БИ.ИспользоватьСубконто(ВидыСубконто.ТМЦ,ВыбТМЦ,1);
БИ.ВыполнитьЗапрос(Дата1,Дата2,"28.1","26",,,"Операция",);
БИ.ВыбратьСубконто(1);
Пока БИ.ПолучитьСубконто(1)=1 Цикл
БИ.ВыбратьСубконто(2);
Пока БИ.ПолучитьСубконто(2)=1 Цикл
Если (БИ.СНД("К")=0)И(БИ.СКД("К")=0)И(БИ.ДО("К")=0)И(БИ.КО("К")=0) Тогда
Продолжить;
КонецЕсли;
ПечТМЦ=БИ.Субконто(2);
Если БИ.ЭтоГруппа()=1 Тогда
Таб.ВывестиСекцию("Группа");
Иначе
Таб.ВывестиСекцию("ТМЦ");
Таб.ВывестиСекцию("Продукция");
КонецЕсли;
БИ.ВыбратьПериоды();
Пока БИ.ПолучитьПериод()=1 Цикл
ПечДокумент=БИ.Операция;
СтрДок=СокрЛП(Строка(БИ.Операция));
СтрДок=СтрДок+" от "+БИ.Операция.Документ.ДатаДок;
Если глЕстьРеквизитШапки("Контрагент",ПечДокумент.Документ.Вид())=Да Тогда
СтрДок=СтрДок+"; "+СокрЛП(ПечДокумент.Документ.Контрагент.Наименование);
КонецЕсли;
Таб.ВывестиСекцию("Док");
КонецЦикла;

Добавлено (01.10.2010, 15:29)
---------------------------------------------
1с Бухгалтерия.

Добавлено (01.10.2010, 15:29)
---------------------------------------------
1с Бухгалтерия.

  • 0

#2   инуля

инуля

      Рядовой

    • Пользователи
    • Сообщений: 16
    • Регистрация: 18-June 09
    • Откуда:Кременчуг , Полтавская Область , Украина

Отправлено 01 October 2010 - 14:36

Нет.
  • 0

#3   AgA

AgA

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 276
    • Регистрация: 07-November 09
    • Откуда:Харьков , Харьковская Область , Украина

Отправлено 01 October 2010 - 19:39

Quote (инуля)
"28.1","26"

Какой документ делает проводку 28.1 - 26 ???
поэтому и не работает
  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных