Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Кто работал с документом ГТД?


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 6

#1   Бестия

Бестия

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 28
    • Регистрация: 04-March 09
    • Откуда: , ,

Отправлено 28 September 2010 - 09:42

Всем привет, помогите разобраться, комплексная конфигурация, документ ГТД. Формируются проводки не так как бы хотелось. Необходимо чтобы в проводке 281-632, по 281 счету в проводке было указано субконто 1, субконто 2 ну и + количество. Вроде и в плане счетов все предусмотрено, а проводки формируются итоговыми суммами по документу (а надо грубо говоря в цикле по строкам), соответственно тогда и в 281 нет аналитики по субконто. Может где то есть какая то загвоздочка и можно быстро решить мою проблему, вместо того чтобы изобретать заново велосипед?

про обработку ЭП_ФормированиеПроводокТорговля

текОперация.Дебет.Счет = текСчетД;
Если ПустоеЗначение(текСчетД) = 0 Тогда
Для Инд = 1 по 3 Цикл
//Если текСчетД.ВидСубконто(Инд) = ВидыСубконто.Партии Тогда
// раскомментировать, если необходимо формирование поводок по счетам учета товаров с аналитикой
// нужно найти или создать партию
спПартия = тбПроводки.ПолучитьЗначение(тбПроводки.НомерСтроки, "СубконтоД"+Инд);
ЗначениеСубк = 0;
Если ТипЗначенияСтр(спПартия)="СписокЗначений" Тогда
глПолучитьПартию(ЗначениеСубк,спПартия.Получить("ТМЦ"),спПартия.Получить("Партия"));
КонецЕсли;
Иначе
ЗначениеСубк = тбПроводки.ПолучитьЗначение(тбПроводки.НомерСтроки, "СубконтоД"+Инд);
КонецЕсли;
КонецЦикла;

Так вот в чем дело: когда я раскоментировала необходимые строки для ведения аналитики по товарам, ничего не произошло, такие же проводки как были такие и остались, как заставить программу видеть 281 счет по товарам.

и ещё один вопрос:
Справочник ЭП_Проводки

Если ПустоеЗначение(ВидСубконто) = 0 Тогда
Если (ТипЗначенияСтр(Счет) = "Счет") и ((Лев(Сч.Код,2) = "28") или (Лев(Сч.Код,2) = "66")) Тогда
// для счетов 28х и 66х запрещено редактирование субконто
Форма.ПолучитьАтрибут(Субконто).Видимость(0);
Форма.ПолучитьАтрибут(тСубконто).Заголовок("Пустое субконто");
Форма.ПолучитьАтрибут(тСубконто).Видимость(1);
Форма.ПолучитьАтрибут(АвтоСубконто).Доступность(0);
Форма.ПолучитьАтрибут(Параметр).Доступность(0);
ИначеЕсли (ТипЗначенияСтр(Счет) = "Справочник")
и (Лев(Сч.Код,2) = "28") Тогда
// для доп.параметров "Счет учета товаров", "Счет учета товаров в рознице"
// и "Счет учета товаров, отданных на комиссию"
// запрещено редактирование субконто
Форма.ПолучитьАтрибут(Субконто).Видимость(0);
Форма.ПолучитьАтрибут(тСубконто).Заголовок("Определяется автоматически");
Форма.ПолучитьАтрибут(тСубконто).Видимость(1);
Форма.ПолучитьАтрибут(АвтоСубконто).Доступность(0);
Форма.ПолучитьАтрибут(Параметр).Доступность(0);
Иначе
........
и т.д.

почему ЗАПРЕЩЕНО РЕДАКТИРОВАНИЕ СУБКОНТО по 28 счету?

Помогите разобраться, спасибки)

  • 0

#2   Polukuzov

Polukuzov

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 324
    • Регистрация: 23-April 08
    • Откуда: , ,

Отправлено 28 September 2010 - 10:28

+ Количество это только в бухгалтерии или в комплексной при выключеном участке "Торговля+склад"
  • 0

#3   Бестия

Бестия

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 28
    • Регистрация: 04-March 09
    • Откуда: , ,

Отправлено 28 September 2010 - 10:40

Это в комплексной, при чем все участки включены, или я так думаю что включены(

Активные компоненты - Бухгалтерия, Торговля+Склад, Зарплата+Кадры

Может я не правильно ответ поняла?

Тогда вопрос, как лучше поступить? Выключить Торговлю?

  • 0

#4   Ardi

Ardi

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 958
    • Регистрация: 27-January 09
    • Откуда:Столица

Отправлено 28 September 2010 - 10:58

На одном из форумов было описание где комментировать, чтобы стало проводить в разрезе аналитики.
  • 0

#5   Бестия

Бестия

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 28
    • Регистрация: 04-March 09
    • Откуда: , ,

Отправлено 28 September 2010 - 11:06

Спасибо конечно же за совет, но я уже инет рою неделю, если бы смогла сама найти , наверно здесь бы не просила помощи))))) На каком форуме хотябы?
  • 0

#6   Ardi

Ardi

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 958
    • Регистрация: 27-January 09
    • Откуда:Столица

Отправлено 28 September 2010 - 15:55

_http://club.dtkt.com.ua/list.php?18
  • 0

#7   Бестия

Бестия

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 28
    • Регистрация: 04-March 09
    • Откуда: , ,

Отправлено 28 September 2010 - 16:12

Ardi Спасибочки, изучаю)))

Арди, это то что нужно)))) Спасибо ещё раз, помогло реально на dtkt. kiss

  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных