Перейти к содержимому

Перейти
Перейти

Как создать документ установка цен номенклатуры УТП 1,2


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 3

#1   Сергей Панченко 0

Сергей Панченко 0

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 03-June 16

Отправлено 03 June 2016 - 12:35

ак создать документ установка цен номенклатуры УТП 1,2?


  • 0

#2   gaz21org

gaz21org

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 01-September 16

Отправлено 01 September 2016 - 12:23

Программно типа так:
 
ДокументУЦ1 = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
ДокументУЦ1.Дата = ТекущаяДата()-24*60*60;
НовТЦ = ДокументУЦ1.ТипыЦен.Добавить();
НовТЦ.ТипЦен = Справочники.ТипыЦен.НайтиПоНаименованию("Розничная");
 
Для инд = 2 По КоличествоСтрок Цикл
 
НовСтр = ДокументУЦ1.Товары.Добавить();
НовСтр.Номенклатура = Нов.Ссылка;
НовСтр.Валюта = Константы.ВалютаУправленческогоУчета.Получить();
ВыборкаЕИ = Справочники.ЕдиницыИзмерения.Выбрать(,Нов.Ссылка);
Пока ВыборкаЕИ.Следующий() Цикл
Если ВыборкаЕИ.ЕдиницаПоКлассификатору = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию("шт") Тогда
ЕИ = ВыборкаЕИ.Ссылка;
Прервать;
КонецЕсли;
КонецЦикла;
НовСтр.ЕдиницаИзмерения = ЕИ;
НовСтр.Цена = Цена;
НовСтр.ТипЦен = НовТЦ.ТипЦен;
НовСтр.СпособРасчетаЦены = НовТЦ.ТипЦен.СпособРасчетаЦены;
 
Сообщить("Записан " + Нов.ПолноеНаименование());
КонецЦикла;
 
ДокументУЦ1.Записать(РежимЗаписиДокумента.Запись);
 

 


  • 0

#3   dreamwaver

dreamwaver

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 13-January 11
    • Откуда: , ,

Отправлено 08 December 2016 - 13:01

А в программе, просто создать документ либо на основании "Поступление Товаров и услуг"


  • 0

#4   irnik777

irnik777

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 16-December 16

Отправлено 16 December 2016 - 19:22

Информация о ценах продажи и тех вспомогательных ценах, которые используются для их расчета, регистрируется с помощью документаУстановка цен номенклатуры. Для регистрации цен используется рабочее место Цены (прайс-лист).

Регистрация цен поставщиков и конкурентов производится документом Регистрация цен поставщиков.

Отпускные цены номенклатуры используются в документах, сопровождающих отгрузку товаров (Соглашение с клиентомЗаказ клиентаРеализация товаров и услуг и т. д.). Цены поставщиков используются при заполнении документов, сопровождающих поступление товаров (Заказ поставщикуПоступление товаров и услуг и т. д.).


  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных