Перейти к содержимому

Перейти
Перейти

Как создать документ установка цен номенклатуры УТП 1,2


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 4

#1   Сергей Панченко 0

Сергей Панченко 0

      Рядовой

    • Пользователи
    • Сообщений: 1
    • Регистрация: 03-June 16

Отправлено 03 June 2016 - 12:35

ак создать документ установка цен номенклатуры УТП 1,2?


  • 0

#2   gaz21org

gaz21org

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 01-September 16

Отправлено 01 September 2016 - 12:23

Программно типа так:
 
ДокументУЦ1 = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
ДокументУЦ1.Дата = ТекущаяДата()-24*60*60;
НовТЦ = ДокументУЦ1.ТипыЦен.Добавить();
НовТЦ.ТипЦен = Справочники.ТипыЦен.НайтиПоНаименованию("Розничная");
 
Для инд = 2 По КоличествоСтрок Цикл
 
НовСтр = ДокументУЦ1.Товары.Добавить();
НовСтр.Номенклатура = Нов.Ссылка;
НовСтр.Валюта = Константы.ВалютаУправленческогоУчета.Получить();
ВыборкаЕИ = Справочники.ЕдиницыИзмерения.Выбрать(,Нов.Ссылка);
Пока ВыборкаЕИ.Следующий() Цикл
Если ВыборкаЕИ.ЕдиницаПоКлассификатору = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию("шт") Тогда
ЕИ = ВыборкаЕИ.Ссылка;
Прервать;
КонецЕсли;
КонецЦикла;
НовСтр.ЕдиницаИзмерения = ЕИ;
НовСтр.Цена = Цена;
НовСтр.ТипЦен = НовТЦ.ТипЦен;
НовСтр.СпособРасчетаЦены = НовТЦ.ТипЦен.СпособРасчетаЦены;
 
Сообщить("Записан " + Нов.ПолноеНаименование());
КонецЦикла;
 
ДокументУЦ1.Записать(РежимЗаписиДокумента.Запись);
 

 


  • 0

#3   dreamwaver

dreamwaver

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 13-January 11
    • Откуда: , ,

Отправлено 08 December 2016 - 13:01

А в программе, просто создать документ либо на основании "Поступление Товаров и услуг"


  • 0

#4   irnik777

irnik777

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 16-December 16

Отправлено 16 December 2016 - 19:22

Информация о ценах продажи и тех вспомогательных ценах, которые используются для их расчета, регистрируется с помощью документаУстановка цен номенклатуры. Для регистрации цен используется рабочее место Цены (прайс-лист).

Регистрация цен поставщиков и конкурентов производится документом Регистрация цен поставщиков.

Отпускные цены номенклатуры используются в документах, сопровождающих отгрузку товаров (Соглашение с клиентомЗаказ клиентаРеализация товаров и услуг и т. д.). Цены поставщиков используются при заполнении документов, сопровождающих поступление товаров (Заказ поставщикуПоступление товаров и услуг и т. д.).


  • 0

#5   DGorgoN

DGorgoN

      Рядовой

    • Пользователи
    • Сообщений: 3
    • Регистрация: 28-August 17

Отправлено 28 August 2017 - 12:44

Для комплексной/упп могу код подсказать:

ДокументОбъект = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
ДокументОбъект.Дата = РабочаяДата;
ЗаполнениеДокументов.ЗаполнитьШапкуДокумента(ДокументОбъект);
 
Для Каждого Стр Из СписокТиповЦен Цикл
СтрокаТипЦен = ДокументОбъект.ТипыЦен.Найти(Стр.ТипЦен, "ТипЦен");
Если СтрокаТипЦен = Неопределено Тогда
СтрокаТипЦен = ДокументОбъект.ТипыЦен.Добавить();
СтрокаТипЦен.ТипЦен = Стр.ТипЦен;
КонецЕсли;
КонецЦикла;
ИндексСтрокиТаблицыЦен = 0;
 
//тзДанных.ВыбратьСтроку();
 
Для Каждого Стр_ Из тзДанных Цикл
Отбор = Новый Структура();
Отбор.Вставить("Номенклатура", Стр_.Номенклатура);
Строки_т = Товары.НайтиСтроки(Отбор);
фВозврат = Ложь;
Для Каждого Стр_т Из Строки_т Цикл
Если Стр_т.Метка = Ложь Тогда
фВозврат = Истина;
КонецЕсли;
КонецЦикла;
Если фВозврат Тогда
Продолжить;
КонецЕсли;
 
СтрНоменклатура = Стр_.Номенклатура.Ссылка.ПолучитьОбъект();
СтрНоменклатура.ДатаОбновленияЦены = ТекущаяДата();
СтрНоменклатура.Записать();
 
ИндексСтрокиТаблицыЦен = ИндексСтрокиТаблицыЦен + 1;
Кд = 1;
Для Каждого Стр Из СписокТиповЦен Цикл
Кд = Кд + 1;
НужнаяЦенаПоТипуЦен = Стр_[Кд];
//Сообщить("****************************");
//Сообщить(Стр_.Номенклатура);
//Сообщить(Кд);
//Сообщить(НужнаяЦенаПоТипуЦен);
СтруктураПоиска = Новый Структура;
СтруктураПоиска.Вставить("Номенклатура", Стр_.Номенклатура);
//СтруктураПоиска.Вставить("ХарактеристикаНоменклатуры", Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка());
СтруктураПоиска.Вставить("ТипЦен", Стр.ТипЦен);
СтрокаТовары = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(ДокументОбъект.Товары, СтруктураПоиска);
Если СтрокаТовары = Неопределено Тогда
СтрокаТовары = ДокументОбъект.Товары.Добавить();
СтрокаТовары.Номенклатура = Стр_.Номенклатура.Ссылка;
СтрокаТовары.ТипЦен = Стр.ТипЦен;
СтрокаТовары.ИндексСтрокиТаблицыЦен = ИндексСтрокиТаблицыЦен;
 
СтрокаТовары.Цена = НужнаяЦенаПоТипуЦен;
СтрокаТовары.Валюта = Стр.ТипЦен.ВалютаЦены;
СтрокаТовары.ЕдиницаИзмерения = Стр_.Номенклатура.ЕдиницаХраненияОстатков;
СтрокаТовары.ПроцентСкидкиНаценки = Стр.ТипЦен.ПроцентСкидкиНаценки;
СтрокаТовары.СпособРасчетаЦены = Стр.ТипЦен.СпособРасчетаЦены;
Иначе
Сообщить("Номенклатура " + СокрЛП(СтрокаТовары.Номенклатура) + " уже есть в списке");
КонецЕсли;
 
 
КонецЦикла;
КонецЦикла;
 
Попытка
ДокументОбъект.Комментарий = "Создан автоматом из загрузки прайса";
ДокументОбъект.Записать(РежимЗаписиДокумента.Запись);
Форма = ДокументОбъект.ПолучитьФорму();
Форма.Открыть();
Сообщить("Создан документ расценки: " + СокрЛП(ДокументОбъект));
Исключение
Сообщить("Не удалось записать документ установки цен: " + ОписаниеОшибки(), СтатусСообщения.Важное);
Отказ = Истина;
Возврат;
КонецПопытки;
 

  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных