Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Помогите разобратся с почтой


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 5

#1   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 20 August 2010 - 11:24

Всем привет. Народ помогите кто знает. Отправляю почту через 1С. Без вложений все работает отлично. Когда же цепляю вложеный файл (Вордовский) не отправляется. Метод "Отправить" возвращает 0;
Code

   
  Почта.АдресПолучателя=СокрЛП(АдресПолучателя);
  Почта.Тема="Тестовое письмо"+" "+ТекущаяДата()+" - "+ТекущееВремя();
  Почта.Тело="Первое письмо";
   
  Почта.Вложения = "D:\RB\Test.docx";//СокрЛП(ИмяФайла);
   
  стр=СокрЛП(ИмяФайла);
  Сообщить("Имя файла выгрузки="+стр);
   
  Если ФС.СуществуетФайл(стр)=1 Тогда
   Почта.Вложения=стр;
  Иначе  
   Сообщить("Не найден файл выгрузки: "+стр);
  КонецЕсли;
   
  Почта.Кодировка="windows-1251";
  Почта.Важность=2;
  Сообщить("Идет отправка сообщения ...");
  Если Почта.Отправить()=1 Тогда
   Сообщить(""+ТекущаяДата()+" - "+ТекущееВремя()+": Сообщение отправлено");
  Иначе                    
   Сообщить(""+ТекущаяДата()+" - "+ТекущееВремя()+": Не удалось отправить сообщение"); а=1/0;
  КонецЕсли;
     Почта.Отключиться();

  • 0

#2   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 20 August 2010 - 12:43

Используется ROM-Mail.
Размер вложений вообще тестовый - по одному слову в файле.

ХЗ, может действительно что-то из сервером?(

  • 0

#3   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 20 August 2010 - 12:51

51kb
  • 0

#4   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 20 August 2010 - 13:05

та ну... неудобно Меня юзеры забодают за такое. им нужно не более одной кнопки жать
  • 0

#5   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 20 August 2010 - 13:32

Спасибо большое plus. Хоть и не так как хотелось, но работает стабильно (что самое главное)
С меня плюс)
  • 0

#6   g789

g789

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 270
    • Регистрация: 11-March 08
    • Откуда:Киев , ,

Отправлено 20 August 2010 - 14:26

через v7plus
Code

Если (ЗагрузитьВнешнююКомпоненту("v7plus.dll")=0) Тогда
  Сообщить("Не удалось обнаружить компоненту V7Plus.dll!");   
  Возврат ;
КонецЕсли;
Попытка   
  Письмо = СоздатьОбъект("AddIn.V7Mail");
Исключение  
  Сообщить("Не удалось создать объект из компоненты V7Plus.dll!");  
  Возврат ;
КонецПопытки;  

Письмо.Подключиться("MAPI");  
Письмо.НовоеСообщение();
Письмо.ДобавитьАдрес(ЭА);
Письмо.ДобавитьФайл(ИмяФ);
Письмо.Заголовок="рироиори";
Письмо.Послать(1);
Письмо.Отключиться();

  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных