Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Подскажыте как правельно


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 5

#1   siniypank

siniypank

      Майор

    • Пользователи
    • PipPipPipPip
    • Сообщений: 84
    • Регистрация: 06-July 09
    • Откуда:Киев , Киев , Украина

Отправлено 22 July 2010 - 07:26

Значит так.
Как правильно зделать, когда при выборе контрагента пустое значения реквизита выдаввало сообшение и возвращало назад.
я писал так, и соответствено не чего не вышло
ЕДРПОУ=Контрагент.ЕДРПОУ;
Если Контрагент.ПолучитьАтрибут(ЕДРПОУ)=0 Тогда
Если ПустаяСтрока(ЕДРПОУ)=0 Тогда
Предупреждение("Пустое значение ЕДРПОУ.");
Возврат;
КонецЕсли;
  • 0

#2   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 22 July 2010 - 07:30

Если ПустоеЗначение(Контрагент.ЕДПОУ) = 1 Тогда
Предупреждение("Пустое значение ЕДПОУ");
КонецЕсли;

все!

  • 0

#3   siniypank

siniypank

      Майор

    • Пользователи
    • PipPipPipPip
    • Сообщений: 84
    • Регистрация: 06-July 09
    • Откуда:Киев , Киев , Украина

Отправлено 22 July 2010 - 07:35

а Возврат????
  • 0

#4   Kazimar

Kazimar

      Подполковник

    • Пользователи
    • PipPipPipPipPip
    • Сообщений: 136
    • Регистрация: 04-February 09
    • Откуда: , ,

Отправлено 22 July 2010 - 07:47

ты книжку читал вообще???
Пример
Процедура ВыборКонтрагента()
Если ПустоеЗначение(Контрагент.ЕДПОУ) = 1 Тогда
Предупреждение("Пустое значение ЕДПОУ");
СтатусВозврата(0);
Иначе
// тело процедуры
КонецЕсли;

КонецПроцедуры

  • 0

#5   siniypank

siniypank

      Майор

    • Пользователи
    • PipPipPipPip
    • Сообщений: 84
    • Регистрация: 06-July 09
    • Откуда:Киев , Киев , Украина

Отправлено 22 July 2010 - 08:05

спасибо большо, как раз изучаю книгу

Добавлено (22.07.2010, 09:05)
---------------------------------------------
а еще добавил в печать, чтобы не смогли распечатать

  • 0

#6   Anderson

Anderson

      Полковник

    • Пользователи
    • PipPipPipPipPipPip
    • Сообщений: 178
    • Регистрация: 05-March 08
    • Откуда: , ,

Отправлено 22 July 2010 - 09:35

А русский язык в школах уже не преподают? Читать же невозможно.
  • 0




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных