Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Печать группы документов.


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 5

#1   AgA

AgA

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 276
    • Регистрация: 07-November 09
    • Откуда:Харьков , Харьковская Область , Украина

Отправлено 01 July 2010 - 20:59

Стоит задача сделать обработку напечатать (послать на принтер все документы) например налоговые за любой период.
Раньше делал аналогичную задачу просто выбирал документы и копировал от туда печатные формы и печатал.
Хочется сделать красивее.
Можно ли обработкой выбирать документ и запускать например процедуру печать() посылать на принтер и закрывать документ и так в цикле.

Может кто нибудь подскажет идею?

  • 0

#2   pepe

pepe

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 1148
    • Регистрация: 12-April 08
    • Откуда: , ,

Отправлено 01 July 2010 - 21:28

Есть готовые обработки. Светани мыло, скину.
Глянь - /forum/3-753-1
  • 0
Спасибо не надо, помог - есть "+" в репутацию.

#3   AgA

AgA

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 276
    • Регистрация: 07-November 09
    • Откуда:Харьков , Харьковская Область , Украина

Отправлено 01 July 2010 - 22:03

Quote (pepe)
Есть готовые обработки. Светани мыло, скину.
Глянь - /forum/3-753-1

Спасибо за ссылки
нужно время переварить информацию. Попробую напишу что получилось.

А есть ли варианты без Dll может более сложные?

  • 0

#4   Zaval

Zaval

      Генерал-полковник

    • Пользователи
    • PipPipPipPipPipPipPipPipPip
    • Сообщений: 1109
    • Регистрация: 26-December 07
    • Откуда: , ,

Отправлено 02 July 2010 - 08:57

Посмотри, как в ТиС БыстраяПродажа сделана - мож, на какую мыслю натолкнет)
  • 0
Киев

#5   Polukuzov

Polukuzov

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 324
    • Регистрация: 23-April 08
    • Откуда: , ,

Отправлено 02 July 2010 - 16:33

Code
Процедура ПриОткрытии()
Если ПустоеЗначение(Форма.Параметр)=0 Тогда
        Если ТипЗначенияСтр(Форма.Параметр)="Строка" Тогда
  Если ВРег(Форма.Параметр)="ПЕЧАТЬ" Тогда
        Печать();
        СтатусВозврата(0);
        Возврат;
  КонецЕсли;  
        КонецЕсли;  
КонецЕсли;

а в своей процедуре

ОткрытьФорму(док.ТекущийДокумент(),"Печать");

да еще в процедуре печать надо предусмотреть вывод на принтер а не на экран

  • 0

#6   AgA

AgA

      Генерал-майор

    • Пользователи
    • PipPipPipPipPipPipPip
    • Сообщений: 276
    • Регистрация: 07-November 09
    • Откуда:Харьков , Харьковская Область , Украина

Отправлено 04 July 2010 - 11:13

Да это то что я и хотел обе идеи похожие и мне подходят так и сделаю.

Спасибо.

  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных