Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Запрет на срабатывание процедуры для неактивной формы


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 3

#1   Smiling

Smiling

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 14-October 09
    • Откуда:Иркутск , Иркутская область ,

Отправлено 16 June 2010 - 04:00

Всем привет!!! Такая проблема: есть документ Продажа из которого при необходимости надо вызывать Новый Документ Продажа (это сделали), при этом в модуле формы документа есть процедура ОбработкаВнешнегоСобытия (для сканирования товара). Проблема в том, как сделать так чтобы эта процедура срабатывала только для той формы которая активна в данный момент, сейчас на деле получается что данная процедура срабатывает вообще для всех открытых документов (т.е. у которых она вообще определена в модуле формы)? Открывать форму модально - такой вариант не подходит...
  • 0

#2   Batchir

Batchir

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 551
    • Регистрация: 19-November 08

Отправлено 16 June 2010 - 07:07

А в типовую какую-нить вера не позволяет заглянуть? В УТ в каждой форме используется конструкция

Code
Процедура ВнешнееСобытие(Источник, Событие, Данные)

     Если Не ВводДоступен() Тогда
      Возврат;
     КонецЕсли;

КонецПроцедуры // ВнешнееСобытие()

Форма (Form)
ВводДоступен (IsInputAvailable)
Синтаксис:
ВводДоступен()
Возвращаемое значение:
Тип: Булево. Истина - ввод данных в форму возможен (форма активна); Ложь - форма не активна.
Описание:
Определяет, возможен ли ввод данных в форму. Может быть использован для того, чтобы определить, активизирована ли текущая форма.
Недоступен на сервере 1С:Предприятие. Не используется в модуле внешнего соединения.
Пример:
Если ВводДоступен() Тогда
Сообщить("Введите текст");
КонецЕсли;

  • 0

#3   Smiling

Smiling

      Лейтенант

    • Пользователи
    • PipPip
    • Сообщений: 45
    • Регистрация: 14-October 09
    • Откуда:Иркутск , Иркутская область ,

Отправлено 16 June 2010 - 07:34

Не позволяет заглянуть отсутствие непосредственно типовой, а не веры ) а за совет - спасибо, буду пробовать ))
  • 0

#4   Batchir

Batchir

      Генерал-лейтенант

    • Пользователи
    • PipPipPipPipPipPipPipPip
    • Сообщений: 551
    • Регистрация: 19-November 08

Отправлено 16 June 2010 - 09:05

Ну насчет веры - это я в шутку конечно, но под рукой типовые конфы иметь желательно. Иногда при их просмотре прозрение посещает. Вот к примеру давно нужно было сделать какое-то храниение версий объектов конфигурации в УТ (т.е. хранение всех изменений данных в справочниках и документах и их последующее сравнение). Думал как же изобрести велосипед, а открыл УПП и увидел готовую (!!!независиую) подсистему моей задачи (самолет, а я за велосипеды берусь), перенос и отладка которой у меня заняло в районе часа.
  • 0



Похожие темы

  Название темы Автор Статистика Последнее сообщение



Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных