Перейти к содержимому


Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

временный расчет


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 6

#1   mike1985

mike1985

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 21
    • Регистрация: 11-June 08
    • Откуда: , ,

Отправлено 02 June 2010 - 16:02

При выборе Партии в документе Выдает:
Ост=Ит.СКД(ТМЦ.Счет,3,,МестоХранения,ТМЦ,ТекущийЭлемент());
{Справочник.Партии.ФормаСписка.ФормаСписка.Модуль(30)}: Для получения итогов по данному периоду требуется временный расчет!
хотя БухИтог и Точка актуальности стоит на сегодня.
  • 0

#2   Sekator

Sekator

      Полковник

    • Пользователи
    • PipPipPipPipPipPip
    • Сообщений: 158
    • Регистрация: 02-March 08
    • Откуда: , ,

Отправлено 02 June 2010 - 16:28

А документ попадает в границу периода бухитогов?
  • 0
Не быть умнее, чем ты есть на самом деле, жить без сомнений, с верой в честь, с душою в теле.

#3   mike1985

mike1985

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 21
    • Регистрация: 11-June 08
    • Откуда: , ,

Отправлено 02 June 2010 - 16:37

Да.Период стоит 2 квартал .
  • 0

#4   Valerka

Valerka

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1305
    • Регистрация: 03-April 08
    • Откуда:Каменец-Подольский

Отправлено 02 June 2010 - 18:44

Ну давайте полный код процедуры.
  • 0
Можно ответить на любой вопрос, если вопрос задан правильно.
Если сообщение помогло Вам - не забудьте нажать на МАЛЕНЬКУЮ стрелочку справа снизу Изображение

#5   mike1985

mike1985

      Сержант

    • Пользователи
    • Pip
    • Сообщений: 21
    • Регистрация: 11-June 08
    • Откуда: , ,

Отправлено 03 June 2010 - 13:27

Valerka,
Функция Остаток()
Если (ТекущийЭлемент().Выбран() = 1) и (МестоХранения.Выбран() = 1) Тогда
ТМЦ = ТекущийЭлемент().Владелец;
Если ПустоеЗначение(Счет) = 1 Тогда
Если МестоХранения.ВидСклада = Перечисление.ВидыСкладов.Оптовый Тогда
Возврат Ит.СКД(ТМЦ.Счет,3,,МестоХранения,ТМЦ,ТекущийЭлемент());
Иначе
Возврат Ит.СКД("28.2",3,,МестоХранения,ТМЦ,ТекущийЭлемент()); // строго по 28.2 (розница)
КонецЕсли;
Иначе
Возврат Ит.СКД(Счет,3,,МестоХранения,ТМЦ,ТекущийЭлемент());
КонецЕсли;
КонецЕсли;
Возврат 0;
КонецФункции
  • 0

#6   Sekator

Sekator

      Полковник

    • Пользователи
    • PipPipPipPipPipPip
    • Сообщений: 158
    • Регистрация: 02-March 08
    • Откуда: , ,

Отправлено 04 June 2010 - 15:03

А код с инициализацией запроса по бухитогам?
  • 0
Не быть умнее, чем ты есть на самом деле, жить без сомнений, с верой в честь, с душою в теле.

#7   Valerka

Valerka

      Генералиссимус

    • Пользователи
    • PipPipPipPipPipPipPipPipPipPip
    • Сообщений: 1305
    • Регистрация: 03-April 08
    • Откуда:Каменец-Подольский

Отправлено 06 June 2010 - 08:50

Ну и где Ит.Рассчитать(...) ? smile
  • 0
Можно ответить на любой вопрос, если вопрос задан правильно.
Если сообщение помогло Вам - не забудьте нажать на МАЛЕНЬКУЮ стрелочку справа снизу Изображение






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных