Перейти к содержимому


Загрузил

Тема поддержки файла Информация

  • Загружен: Mar 02 2014 06:55
  • Последнее обновление: Mar 02 2014 06:55
  • Размер: 15.93К
  • Просмотров: 298
  • Скачан: 1
Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Эмуляция ООП в 1С8

- - - - -



Описание: экспериментально-теоретическое руководство по использованию ООП В 1С8.
Для моделирования свойств объектов прекрасно подойдет объект типа «Структура», где можно хранить любые свойства любого типа.
Для реализации методов объектов будем использовать общие модули, по одному на каждый объект. В этих модулях будем описывать методы объекта в виде функций с именами ТипОбъекта_ИмяМетода. Хотелось бы конечно писать просто Об.ИмяМетода(Параметры), но придется писать примерно вот так: Метод(Об, ИмяМетода, Параметры).
Для передачи параметров опять же будем использовать только один параметр типа структура, который может содержать в себе любое количество параметров. К сожалению 1С не поддерживает вызов процедур с произвольным количеством и порядком вызова параметров.
Каждый объект содержит по ключу «Тип» название своего типа, для вызова соответствующего метода используется документированная функция «Выполнить».
Если метод не найден у объекта, он ищется у предка. Тип предка определяется через вызов у объекта метода Предок, если метод определен.
Если вызываемый метод не определен, система ничего не делает.
В методе можно вызвать метод предка, примерно так Предок(Об, ИмяМетода, Параметры).
Свойства можно назначать непосредственно, но для обеспечения контроля над свойствами лучше использовать функции Установить(Об, Свойство, Зн) и Получить(Об, Свойство).
Можно написать перехватчики событий установки-чтения свойств. Они носят имя ТипОбъекта_Установить и ТипОбъекта_Получить. Если ТипОбъекта_Установить возвращает истину, то свойство устанавливается, если ложь, то нет (этот обработчик может уже установить значения свойства и повторно его ставить не надо или запретить изменение свойства).
Конструктор объекта описывается в функции ТипОбъекта_Создать.
Деструктор объекта описывается в функции ТипОбъекта_Удалить. К сожалению, все вызовы деструкторов нужно вызывать явно, т.к. в 1С 8.0 нельзя отследить момент удаления локальной переменной.
Таким образом для реализации ООП достаточно 6 функций:
· Создать
· Метод
· Предок
· Установить
· Получить
· Удалить
В принципе, объекты 1С 8.0 (документы, справочники и т.п.) можно рассматривать уже как готовые объекты. Действительно, у них можно получить тип. Кроме того, они обладают набором свойств. Таким образом, можно унифицировать работу с объектами через вышеуказанные шесть методов.
И если вместо документа использовать справочник, возможно в коде ничего не придется менять.
Резюме.
ООП в 1С 8.0 можно реализовать легко и красиво, добавив только 6 функций.
Некоторые библиотеки функций удобнее реализовать в виде библиотеки классов.
Например, списание по партиям удобно реализовать в виде объекта ОчередьПартий, а каждое из списаний по товарам, по долгам будет наследовать от базовой очереди, внося новые свойства.
Также можно реализовать библиотеки для работы с файлами, строками и т.п.
Единственно, нужно учитывать, что объектно-ориентированный подход в нашем случае нужно применять там, где прозрачность и понятность разработки важнее быстродействия, т.к. методы интерпретатора Выполнить все же медленнее скомпилированного кода 1С.
И все же, если в очередном релизе появится метод ВыполнитьФункцию(Имя Функции, Параметры), все ограничения по скорости будут сняты и ООП восторжествует. Видите, как для этого мало надо!
Кроме того, если использовать функцию Шаблон и вместо Структуры Список значений, то подобное ООП можно реализовать и в 7.7, правда вся реализация методов должна быть в одном глобальном модуле (в семерке нельзя реализовать несколько модулей).

Приложение.
Здесь приведены операторы для функций.

Создать = СоздатьОбъект ТипОбъекта
Метод = Об.Метод(Параметры)
Предок = Об::Метод(Параметры)
Установить = Об.Свойство=Зн;
Получить = Об.Свойство=Получить;
Удалить = УдалитьОбъект Об.
//Реализация объекта 1
Функция Объект1_Создать(Прм="")
КонецФункции
Функция Объект1_Печать(Я, Прм="")
Сообщить("Я объект 1");
Возврат 1;
КонецФункции

Функция Объект1_Известить(Я, Прм="")
Сообщить(Получить(Я, "Информация"));
Возврат 1;
КонецФункции


//Реализация объекта 2
Функция Объект2_Создать(Прм="")
КонецФункции

Функция Объект2_Предок(Я, Прм="")
Возврат "Объект1";
КонецФункции

Функция Объект2_Известить(Я, Прм="")
Сообщить("1С 8.0 - объектно-ориентированная среда!!! "+Прм);
КонецФункции


//Реализация объекта 3
Функция Объект3_Создать(Прм="")
КонецФункции

Функция Объект3_Предок(Я, Прм="")
Возврат "Объект2";
КонецФункции

Функция Объект3_Печать(Я, Прм="")
Сообщить("Я объект 3");
Предок(Я, "Известить", "Верите?");
Возврат 3;
КонецФункции


Функции, реализующие ООП В 1С 8.0

//Вызывает функцию, определенную в предке
Функция Предок(Об, Метод, Прм="", Сработал=ложь)
Перем Результат, Тип, Предок;

//Получаем тип объекта
Тип=Об.Тип;

Сработал=истина;
Попытка
Предок=Вычислить(Тип+"_Предок(Об, Прм)");
Попытка
Результат=Вычислить(Предок+"_"+Метод+"(Об, Прм)");
Возврат Результат;
Исключение
КонецПопытки;
Исключение
КонецПопытки;
Сработал=ложь;
Возврат Неопределено;
КонецФункции

Функция Метод(Об, Метод, Прм="", Сработал=ложь)
Перем Тип;

Сработал=истина;

//Получаем тип объекта
Тип=Об.Тип;

//Сначала пробуем просто вызвать метод самого объекта
Попытка
Возврат Вычислить(Тип+"_"+Метод+"(Об, Прм)");
Исключение
КонецПопытки;

Сработал=ложь;
//Затем пробуем вызвать метод у предка объекта
Возврат Предок(Об, Метод, Прм);
КонецФункции


//Создает объект
Функция Создать(Тип, Прм="")
Об=Новый Структура;
Об.Вставить("Тип",Тип);
Метод(Об, "Создать", Прм);
Возврат Об;
КонецФункции

Функция Установить(Об, Свойство, Зн)
Перем Сработал, Рез;
Прм=Новый Структура;
Прм.Вставить("Свойство", Свойство);
Прм.Вставить("Значение", Зн);
Рез=Метод(Об, "Установить", Прм, Сработал);
Если (Не Сработал) ИЛИ (Рез=Истина) Тогда
Об.Вставить(Свойство, Зн);
КонецЕсли;
Возврат Зн;
КонецФункции

Функция Получить(Об, Свойство)
Перем Сработал, Зн;
Прм=Новый Структура;
Прм.Вставить("Свойство", Свойство);
Зн=Метод(Об, "Получить", Прм, Сработал);
Если Не Сработал Тогда
Если Не Об.Свойство(Свойство, Зн) Тогда
Зн=Неопределено;
КонецЕсли;
КонецЕсли;
Возврат Зн;
КонецФункции


Процедура Сформировать(Элемент)
// Вставить содержимое обработчика.
Об1=Создать("Объект1");
Об2=Создать("Объект2");
Об3=Создать("Объект3");
Рез1=Метод(Об1, "Печать");
Рез2=Метод(Об2, "Печать");
Рез3=Метод(Об3, "Печать");
Сообщить("Результаты: "+Рез1+" "+Рез2+" "+Рез3);
Сообщить("Сначала информации нет:"+Получить(Об1, "Информация"));
Установить(Об1, "Информация", "Я храню некую информацию");
Сообщить("Потом мы ее устанавливаем:"+Получить(Об1, "Информация"));
КонецПроцедуры



Администрация не несет ответственности за возможный вред, причиненный этим материалом.





  • 8618 Всего файлов
  • 9 Всего категорий
  • 45 Всего авторов
  • 22827 Всего загрузок
  • Акт списания ТМЦ Последний файл
  • kozavva Последний автор

3 посетителей за последние 15 минут

0 пользователей, 2 гостей, 0 анонимных


Google (1)