Перейти к содержимому


Загрузил

Тема поддержки файла Информация

  • Загружен: Mar 02 2014 06:01
  • Последнее обновление: Mar 02 2014 06:01
  • Размер: 10.38К
  • Просмотров: 911
  • Скачан: 9
Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Правка регистров

- - - - -



Описание: обработка позволяет считать данные из любого регистра накопления, регистра бухгалтерии или регистра сведений, отредактировать их и записать заново. Для этого нужно выбрать нужный регистр. Затем уставновить соответствующие значения в поля отбора. Для регистра подчиненного регистратору необходимо только указать сам регистратор. Нажать кнопку Прочитать. Появятся данные из регистра, которые возможно будет отредактировать. После чего эти данные вносятся в базу с помощью кнопки Записать.

Функциональные возможности:
- Регистр накопления возможно редактировать не только с отбором по регистратору, но и с отбором по одному из его измерений (см. рисунок "Отбор по измерениям регистра накопления").
- Записи регистра возможно редактировать по данным в первой строке по определенному полю. Для этого нужно после прочтения записей регистра установить курсор в нужной колонке, и по нажатию кнопки "Заполнить по первой строке" будет произведена в выбранной колонке по всем строкам на значение в первой строке.
- Записи регистра возможно редактировать произвольным образом. Для этого после прочтения записей регистра нужно набрать текст справа и нажать кнопку Обработать.
- Если необходимо, чтобы набор записей регистра записывался с признаком ОбменДанными.Загрузка, то нужно установаить соответствующий признак. (см. рис. "Признак Загрузка").
- Редактирование данных задним числом для пользователей с полными правами не проблема. Для этого снимается галочка "Применять дату запрета для пользователей с полными правами". Если ее по каким-то причинам снимать нежелательно или невозможно, но возможна работа с регистром, который нужно отредактировать, то данной обработкой возможно отредактировать доступный регистр, но для этого нужна небольшая доработка конфигурации.
Для избежания процедуры проверки запрета редактирования задним числом используется дополнительный параметр: "НаборЗаписей.ДополнительныеСвойства.Вставить("НеПроверятьДату", ИстинА);".
Для его работы необходимо внести изменения в процедуру проверки даты запрета.
В УПП в обработчики подпискок на события ПередЗаписьюРегистраНакопленияДатаЗапретаРедактирования и ПередЗаписьюРегистраСведенийДатаЗапретаРедактирования можно внести соответственно такие изменения:

// Проверка возможности изменения записей регистров (дата запрета изменения данных)
//
Процедура ПередЗаписьюРегистраНакопленийПроверкаДоступностиПериода(Источник, Отказ, Замещение) Экспорт

Если Отказ ИЛИ Источник.ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

//-
//ПроверкаПериодаЗаписейРегистров(Источник, Отказ, "РегистрНакопления");
//-
//+
Если Источник.ДополнительныеСвойства.Свойство("НеПроверятьДату")
И Источник.ДополнительныеСвойства.НеПроверятьДату Тогда
Отказ = ЛожЬ;
Иначе
ПроверкаПериодаЗаписейРегистров(Источник, Отказ, "РегистрНакопления");
КонецЕсли;
//+
#Если НЕ ВнешнееСоединение Тогда
Если Отказ Тогда
Сообщить("Редактирование данных этого периода запрещено. Изменения не могут быть записаны...", СтатусСообщения.Важное);
КонецЕсли;
#КонецЕсли
КонецПроцедуры // ПередЗаписьюРегистраНакопленийПроверкаДоступностиПериода
// Проверка возможности изменения записей регистров (дата запрета изменения данных)
//
Процедура ПередЗаписьюРегистраСведенийПроверкаДоступностиПериода(Источник, Отказ, Замещение) Экспорт

Если Отказ ИЛИ Источник.ОбменДанными.Загрузка Тогда
Возврат;
КонецЕсли;

//-
//ПроверкаПериодаЗаписейРегистров(Источник, Отказ, "РегистрНакопления");
//-
//+
Если Источник.ДополнительныеСвойства.Свойство("НеПроверятьДату")
И Источник.ДополнительныеСвойства.НеПроверятьДату Тогда
Отказ = ЛожЬ;
Иначе
ПроверкаПериодаЗаписейРегистров(Источник, Отказ, "РегистрСведений");
КонецЕсли;
//+
#Если НЕ ВнешнееСоединение Тогда
Если Отказ Тогда
Сообщить("Редактирование данных этого периода запрещено. Изменения не могут быть записаны...", СтатусСообщения.Важное);
КонецЕсли;
#КонецЕсли
КонецПроцедуры // ПередЗаписьюРегистраСведенийПроверкаДоступностиПериода



Администрация не несет ответственности за возможный вред, причиненный этим материалом.





  • 8618 Всего файлов
  • 9 Всего категорий
  • 45 Всего авторов
  • 22868 Всего загрузок
  • Акт списания ТМЦ Последний файл
  • kozavva Последний автор

8 посетителей за последние 15 минут

0 пользователей, 7 гостей, 0 анонимных


Yandex (1)