Перейти к содержимому


Загрузил

Тема поддержки файла Информация

  • Загружен: Mar 02 2014 05:59
  • Последнее обновление: Mar 02 2014 05:59
  • Размер: 6.7К
  • Просмотров: 464
  • Скачан: 2
Услуги программиста 1С
Профессиональные программисты 1С.
Весь комплекс услуг сопровождения 1С.

Курсы 1С
Бухгалтерам, менеджерам
и программистам.
Бесплатно!
Живое индивидуальное обучение по 1С.

Создание подчиненных документов ЗаказНаПроизводство на основании основного заказа на производство (УПП 8.2, ред. 1.3)

- - - - -



Описание: создана для того, чтобы пользователи не забыли создать все необходимые документы ЗаказНаПроизводство, чтобы произошло полное разузлование выходного изделия, которое упоминается в главном документе.

В форме обработки выбирается главный документ. При нажатии на кнопку «Заполнить» создаются подчиненные документы (см. скриншот «Запуск обработки»).
Обработку можно оформить для запуска из журнала ЗаказыНаПроизводство и/или Формы списка документа ЗаказНаПроизводство с соответствующими доработками в этих журналах. В данном случае нужно выбрать строку журнала с нужным (основным) документом и нажать на кнопку «Оформить заказы на основании» (см. скриншот «Запуск из журнала»).

Доработки конфигурации.
1. Создан реквизит документа ЗаказНаПроизводство – «ДеревоЗаказов», тип - Строка (200). Этот реквизит для наглядности нужно поместить в журнал ЗаказыНаПроизводство и Форму списка самого документа. По нему можно легко увидеть подчинение документов сразу в журнале, не открывая структуру подчиненности.
Принцип заполнения реквизита «ДеревоЗаказов» следующий:
НомерОсновногоДокумента_НомерДокументаУровня2_ НоменДокументаУровня3 и т.д.
Номера документов, заполняющие «ДеревоЗаказов» берутся без префиксов и без начальных нулей.
2. В форме документа ЗаказНа Производство в процедуру формы ПриЗаписи нужно добавить код следующего содержания:
Процедура ПриЗаписи(Отказ)
//....Ваша обработка......
//....Ваша обработка...
// В ДеревоЗаказов вставляем № документа, если это 1-й док-т дерева,
//т.е. ОсновнойЗаказНаПроизводство - не заполнено.
Если НЕ ЗначениеЗаполнено(Номер) Тогда
УстановитьНовыйНомер(ОсновнойЗаказНаПроизводство.Организация.Префикс);
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ДеревоЗаказов) Тогда
цц = "0123456789";
ном = "";
длинаНомера = СтрДлина(Номер);
ии = длинаНомера;
Пока ии > 0 Цикл
Если Найти(цц,Сред(Номер,ии,1)) > 0 Тогда
ном = Сред(Номер,ии,1) + ном;
Иначе
Прервать;
КонецЕсли;
ии = ии - 1;
КонецЦикла;
ном = Строка(Формат(Число(ном),"ЧГ=0"));
Если НЕ ЗначениеЗаполнено(ОсновнойЗаказНаПроизводство) Тогда
//Вытаскиваем №
ДеревоЗаказов = ном;
Иначе
Если ЗначениеЗаполнено(ОсновнойЗаказНаПроизводство.ДеревоЗаказов) Тогда
ДеревоЗаказов = СокрЛП(ОсновнойЗаказНаПроизводство.ДеревоЗаказов) + "_" + ном;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецПроцедуры
При желании, этот новый реквизит «ДеревоЗаказов», можно вывести на форму.



Администрация не несет ответственности за возможный вред, причиненный этим материалом.





  • 8618 Всего файлов
  • 9 Всего категорий
  • 45 Всего авторов
  • 22872 Всего загрузок
  • Акт списания ТМЦ Последний файл
  • kozavva Последний автор

3 посетителей за последние 15 минут

0 пользователей, 3 гостей, 0 анонимных