Перейти к содержимому

Перейти
Перейти

Самый рейтинговый контент


#24255 компонента "Управление распределенными информационными базам

Написано Valerka на 12 March 2011 - 20:54

Inchik, во вложении smile

Прикрепленные файлы

  • Прикрепленный файл  DistrDB.dll   24.05К   0 Количество загрузок:

  • 13


#42650 Загрузка/изменение справочника Номенклатура (дополнительных сведений и реквиз...

Написано Доктор Шульц на 15 April 2014 - 15:08

Название: Загрузка/изменение справочника Номенклатура (дополнительных сведений и реквизитов) из Excel для УТ11 (Управляемая форма)

Добавил: Доктор Шульц

Добавлен: 02 Mar 2014

Категория: Обработки, отчеты


Обработка позволяет загрузить справочник Номенклатура из Excel (вместе со штрихкодами, дополнительными сведениями и реквизитами).
Есть возможность поиска номенклатуры по штрихкоду/артикулу/наименованию/Коду (порядок поиска определяется положением строки настроек полей Excel с установленным флагом "Ключ поиска" сверху вниз).
Если номенклатура найдена, то она изменяется в соответствии с Excel (в том числе доп. сведения и доп. реквизиты). Если не найдена, то создается новая номенклатура если установлен флаг "Создавать новую номенклатуру".
Есть возможность вывода лога загрузки.


Нажмите здесь, чтобы скачать файл


  • 12


#5678 область таблицы

Написано sVasilich на 20 November 2008 - 15:00

Модно-ли включить в область таблицы включить нескоько ячеек, которые не расположены рядом друг с другом. Например R1C1 и R15C12.
Я понимаю так:
Code
Таб=СоздатьОбъект("Таблица");
МояОбласть=Таб.Область(адрес);

Как правильно задать переменную адрес?
  • 8


#5611 Перенос данных в "Бухгалтерия для Украины"

Написано shurik_shurik на 18 November 2008 - 20:42

Ситуация в следующем, есть две одинаковые конфы... каждый месяц нужно организовать переброс доков (за исключением некоторых) в другую базу, кто что посоветовать...
пробовал МОД, и ище пару похожих вариантов, не подошло, думаю написать что-то свое, на основе OLE...

Главная проблема - справочники (особенно переодические реквизиты)....
Ище одна проблема, это удаление доков в уже "загруженных периодах"

У кого какие соображения????

  • 8


#5514 Целая часть числа

Написано Roma на 13 November 2008 - 22:47

Так Цел(), вернет 1, а мне надо, если хоть что-то есть после запятой, то 2
  • 8


#5354 Анекдоты

Написано Mid на 06 November 2008 - 14:27

- Уважаемый Александр! В нашей бухгалтерии снова не работает клиент-банк.
- Уважаемая Марина, я хз как Вы его запускаете - но у меня все работает!
- Что значит хз?
- Хочу Знать...
  • 8


#4806 Поле цена с НДС в счет фактуре.

Написано g789 на 21 October 2008 - 09:25

Quote (chei)
Хотел себе "удобство" сделать

Для удобства biggrin.gif - примерно так:
1.Добавить атрибут табличной части документа - ЦенаСНДС - Тип знасения - "Число", длина 12, точность 2;
2.В редакторе формы добавить реквизит в таблицу значений - ЦенаСНДС;
3.На закладке "Дополнительно" свойства поля ввода ЦенаСНДС прописать процедуру реагирующую на изменение цены с ндс - ИзмЦенаСНДС();
В модуле формы добавить под процедурой ИзмЦенаБезНДС()

Процедура ИзмЦенаСНДС
    СтавкаНДС = ВидНДС.Ставка.Получить(ДатаДок);
   ЦенаБезНДС = Окр(ЦенаСНДС / (1 + СтавкаНДС),2);
   ИзмЦенаСНДС();
КонецПроцедуры
 
примерно так.

 


  • 8


#31611 Загрузка номенклатуры из Excel для УТ 3

Написано UACLUB на 14 October 2013 - 17:39

Это универсальная обработка, она подходит для разных конфигураций но только для тех которые работают на "обычных формах", а УТ 3 для Украины (аналог УТ 11 для РФ) работает на "управляемых формах". Платные варианты такой обработки для управляемых форм точно есть на инфостарте, можно там же поискать бесплатные.


  • 8


#52501 Перенос данных из 7.7 в 8.2

Написано kidaloff на 22 October 2014 - 11:33

Название: Перенос данных из 7.7 в 8.2

Добавил: kidaloff

Добавлен: 22 Oct 2014

Категория: Обработки, отчеты


Обработка предназначена для переноса проводок из 7.7 в 8.2. Она может помочь решить проблему, если есть необходимость перенести все проводки от начало и до конца 8.2 которые были сделаны в базе 7.7 при этом не нужно переносить все документы из 7.7. А также можно использовать для перехода с версии 7.7 на 8.2. Делалась под Российские конфигурации! Конфигурации 7.7 Бухгалтерский учет, редакция 4.5 Упрощенная система налогообложения Бухгалтерский учет (бюджет) ред. 6.1 Конфигурации 8.2 Бухгалтерия предприятия, редакция 1.6 Бухгалтерия предприятия, редакция 2.0 Бухгалтерия автономного учреждения КОРП, редакция 2.0 Бухгалтерия предприятия КОРП, редакция 3.0


Нажмите здесь, чтобы скачать файл


  • 7


#5203 не открывается конфигуратор

Написано kozyr76 на 30 October 2008 - 21:21

Вот именно, что не открывается конфиг. Я попробывал в свойствах системы поменять переменные среды на с:\temp, не помогло. Пробывал на другом компе, где все работает, запустить mountvol, далее в конфе загрузить архив по пути указаному в mountvol, но не удалось, снова вернул как было, закачал на флэшку базу, перехожу на другой комп...и, конфигуратор снова не открывается. Может можно как-то по другому?

Добавлено (30.10.2008, 21:21)
---------------------------------------------
Хорошо, как прописать путь к временным файлам в 1с 7.7?

  • 7


#51815 Консоль запросов 1С 7.7

Написано Den Luxor на 06 August 2014 - 16:38

Название: Консоль запросов 1С 7.7

Добавил: Den Luxor

Добавлен: 06 Aug 2014

Категория: Обработки, отчеты


Консоль запросов для стандартных запросов 7.7, с возможностью установки параметров.
Консоль запросов для стандартных запросов 7.7,обычный вывод в тз результата запроса ,единственно с возможностью установки параметров.


Нажмите здесь, чтобы скачать файл


  • 7


#5022 АнализТекущейЗадолженности

Написано Vofka на 28 October 2008 - 08:58

Такая ситуация:

Есть отчёт Анализ текущей задолженности. В справочнике Контрагентты есть вкладка Кредиты. На этой вкладке указывается отсрочка платежа (покупателю, в данном случае). Там же стоит галочка на флажке Глубина кредита покупателю в календарных днях, а отчёт показывает отсрочку в банковских днях!

  • 7


#4847 предлагаю вакансию Програмиста 1С

Написано Fynjy на 22 October 2008 - 16:59

От жеж ... Тут бы опубликовали ... Кто первый решил того и взяли бы ...
  • 7


#4807 Группировка

Написано g789 на 21 October 2008 - 09:31

Quote (ivisor)
Fynjy, Roma, а чем вам полох вариант?:
Code

Пока ПолучитьСтроку() = 1 Цикл
Пока (СокрЛП(Признак))="2" Цикл
УдалитьСтроку();
КонецЦикла;
КонецЦикла;


Будут пропуски строк.
я делаю примерно так
Code
Для н=1 По КоличествоСтрок() Цикл
  ПолучитьСтрокуПоНомеру(н);
  Если (СокрЛП(Признак)) = "2" Тогда
   УдалитьСтроку();  
   н = н - 1;
  КонецЕсли;
КонецЦикла;

  • 7


#4599 Группировка

Написано Roma на 14 October 2008 - 15:44

Всем привет! Вобщем проблему я вроде как решил, наверное не очень правильно, но главное что работает: у меня 3 таблицы, и полуфабрикаты я делаю в отдельном документе, тоже через 3 таблицы (потому, что не придумал как все это в одном доке по счетам раскидать)... Но осталось два вопроса:
1. Допустим папка состоит из 1 механизма и 2 колец, надо сделать 10 папок, мехнаизмов на складе - 5 и колец 10, т.е. собрать можно 5 шт, а у меня получается, при проходе по строчкам, сначало снимается 5 механизмов, т.е. 10 папок - 5, а затем еще и 10 колец = собрать можно 0. Как свернуть таблицу по максимальному значению?
2. В процесе прохода по таблицам у меня в табличную часть дока временно добавляются полуфабрикаты (которых нехватает), (готовая прод. от полуфабрикатов отличается признаком: гот. прод. - 1, полуф. - 2) так вот эта процедура на кнопке, когда нажимаешь первый раз, то все ОК, но пользователь может нажать много раз..., поэтому перед добавлением я удаляю строки с признаком 2, так вот вопрос, почему то удаляются все строки, кроме одной. Может кто слышал про такое...
  • 7


#4588 Группировка

Написано sVasilich на 14 October 2008 - 10:42

Quote (shurik_shurik)
Я придерживаюсь своего мнения, которое было выложено в #12 сообщении

если я правильно понял, методы похожи. smile
на счет для "данного товара": для каждого изделия нужно проверять остатки на складе отдельно. В одном из постов был вопрос, "что делать если несколько изделий требуют один материал?". Наверное 2 ТЗ придется делать: общую для всего документа и для изделия.
В общую заносим остатки по всем используемым материалам на складе. Для изделия - материалы для изделия текущей строки. Проверяем наличие ресурсов для текущего изелия, выводим данные о том сколько можем его сделать. Обновляем ТЗ для всего документа. Проверяем следуюющее.
На счет приоритетов я наверно некорректно выразился: имелл в виду что надо считать сначала первый товар, потом второй и т.д.
Повторюсь, 1с знаю плохо, shurik_shurik, если не понял твой метод и нафлудил - прошу извинить biggrin
  • 7


#4480 IT-Jam в Киеве

Написано LAVSO на 09 October 2008 - 14:13

Кузьмич, я рада, що ви трохи посміялись. Сміх продовжує життя, виходить я вам допомогла продовжити життя, хоч ви мені не захотіли допомогти smile
/forum/3-625-1
  • 7


#5653 Позаказный учет в комплексной

Написано liksoft на 20 November 2008 - 08:58

А по Взаиморасчетам аналитика только по регистрам. Но ведь 2 субконто 361 и 631 заполняется при проведении документов. Разве из недостаточно??? Тогда какая конкретно аналитика нужна по 361 и 631???
  • 8